summaryrefslogtreecommitdiff
path: root/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild')
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
new file mode 100644
index 000000000000..1e4d18cd3495
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ insopts -m755
+ newins "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/phpdoc
+}