summaryrefslogtreecommitdiff
path: root/dev-php/phing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-php/phing
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-php/phing')
-rw-r--r--dev-php/phing/Manifest2
-rw-r--r--dev-php/phing/phing-2.16.3.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/phing/Manifest b/dev-php/phing/Manifest
index f46f095785ac..c79f1149d33b 100644
--- a/dev-php/phing/Manifest
+++ b/dev-php/phing/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 418 BLAKE2B 8999ecee030a7d3eab49102bea8bf3aedff8c0e35021947279fee65ed9c0fa2f6bdc923a5e48437f314623cfed7545b3f4e30e8eb19610091c13a897c93278ca SHA512 81a22775a38d08e681e0f0a97fd6f125065be86fb491894f397cb25cc8240a7038b6cf061c77cc0c4837cc5a68aef909fe3a94ae84165a5f358050fac0164cd1
DIST phing-2.16.1.tgz 4149013 BLAKE2B 266c124237d437361e9e18a42c9358fc18cfacfaa798a3a92a31858b7c1af847cde2cac43e0fcfe3759e8291639de9ec564f977fe00939316dbacdfd266e4e92 SHA512 e0832396dac9fbd43680f01acfa55f3ed2819726ace1db4ec9addf18c9c023c4f63143c6a63bbe1b16c2bd19dba54f503efdc77d772a3239bc8f9efe0ab375bb
+DIST phing-2.16.3.tgz 858508 BLAKE2B f1125420989af4ec9d1795044d96131a78012d5000eb8adaf9d076f4e2bbceeab0f11b9a24b79425fff179b4ec9dbe5a33aba65dbd4de6b70e64c1cb7c243004 SHA512 b564ddea969bd2a538e09768f6e4d88e9e61ecf6d783db4e328ef9be00099b1fee6ac6dac49b61bab6243e61969131d22869e95b8f063b9c233fd23afa314d30
EBUILD phing-2.16.1.ebuild 1552 BLAKE2B 4ebbe638f537094ae2fc898f9fa9f3d1d6fa3955a4b0ba7f2da50cf03efc24e42917ccb02caed1855858ea8dea7885a0e5b7142848c42cec3cd35cfcc1842cbd SHA512 3e10a755f846b85b70e405839537c237c373b4c1a3428157077d2621ce023e4d0d59573e81d706a8cf85e505329b7511153bbc8e92292b7475db813a5ca55773
+EBUILD phing-2.16.3.ebuild 1549 BLAKE2B bb4a01d8042712ccc0e0562cd38be6569af3b368735013dd247ffc1de2c0aef73e7b707b443c14c379626aa334b1ddb3d4a5b659b49f1ee46d43b5d42d43231f SHA512 7936e5cb4e5d1487fd8ed20d44d334ec182ff285139a57f51c5fd5d4163bc0ae5d8f6c3619b9450b466d7572f2b641fb8065a1a40f3d1e5abb2631c51ffdd7ad
MISC metadata.xml 471 BLAKE2B eed7a2c37fef52fce309821dbeb3dd30276d438cdd3b00b709b8fd5c5814f2e25c48465eaa1abd7aef190f3a3b1c502be1066e6b8479761001c71ffd94f91999 SHA512 a0b77b3717c96c2aa8807f967c5c5a61dbcaa543ac7467a6f36bfdb9a74897b975d543ea2515180718cd016d7ec72989e985ce45c87cec04923f9226a2c97254
diff --git a/dev-php/phing/phing-2.16.3.ebuild b/dev-php/phing/phing-2.16.3.ebuild
new file mode 100644
index 000000000000..a85ce522c145
--- /dev/null
+++ b/dev-php/phing/phing-2.16.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="https://www.phing.info/"
+SRC_URI="https://www.phing.info/get/${P}.tgz"
+
+LICENSE="FDL-1.3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples minimal zip"
+
+RDEPEND="dev-lang/php:*[cli,xml,xslt,zip?]
+ dev-php/symfony-yaml
+ !minimal? (
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-PEAR_PackageFileManager
+ dev-php/PEAR-VersionControl_SVN
+ dev-php/PHP_CodeCoverage
+ dev-php/phpDocumentor
+ dev-php/phpmd
+ dev-php/phpunit
+ dev-php/simpletest
+ dev-php/xdebug
+ )"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodoc CHANGELOG.md CREDITS.md README.md
+ dodoc -r docs/docbook5/en/output/hlhtml
+ use doc && dodoc -r docs/api
+ use examples && dodoc -r docs/example
+
+ # Install the executable (and the PHP file it wraps) outside of the
+ # PHP include directory, since nobody should be including it.
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ insinto "/usr/share/${PN}/bin"
+ doins "bin/${PN}.php"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ # Phing tries to get the version number from this file.
+ insinto "/usr/share/${PN}/etc"
+ doins etc/VERSION.TXT
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ # But install the library under /usr/share/php.
+ insinto "/usr/share/php"
+ doins -r "classes/${PN}"
+}