summaryrefslogtreecommitdiff
path: root/dev-php/phar-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phar-utils
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phar-utils')
-rw-r--r--dev-php/phar-utils/Manifest4
-rw-r--r--dev-php/phar-utils/files/autoload.php8
-rw-r--r--dev-php/phar-utils/metadata.xml21
-rw-r--r--dev-php/phar-utils/phar-utils-1.0.0.ebuild22
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/phar-utils/Manifest b/dev-php/phar-utils/Manifest
new file mode 100644
index 000000000000..4bf77d3b054d
--- /dev/null
+++ b/dev-php/phar-utils/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 261 BLAKE2B e3aef92345eb95b936a4b3edc12e9518804c9f75087d73deec3882c113a913a17f2bad46c6a2e9c7c6e396e795863cf930775b566cccee77fb275013fb29c0bb SHA512 9e4820ee718f642ff95baaff3cd848b868465d5b6538377517f384aa6e0198e0cd3298e98ddd4ffa86e6669f438a6ce8236f4d56440e9e77b3df20599699753d
+DIST phar-utils-1.0.0.tar.gz 3152 BLAKE2B c4dfd3d659989bc22adcc14c79e28d623753988742d2fdd178dfd98590b629083ad85c9f112ab23c6213fa70cdad838ebbdc01c45551892ed9a20a3374abd28c SHA512 bf3d7074a3f1101a7f03e8fb8a5bc1456674bf2f9ded6a5fc5fb2f892c1cc3c4643fab6c003851ed12ea16ce6390f482cf897beee7d7c38922b6c54c90b0934e
+EBUILD phar-utils-1.0.0.ebuild 540 BLAKE2B db97fcd60bf5c51010548dd186b3957f277b2a2818d8cd60b7cbc62457a96850956012a44ceddb663931fb2ee4035cadca813373ce5f16c9046c667abcc47ef3 SHA512 d3e797a0fdfa3a43717d8947fb0b4e1d1dc3720ef9303dd8dd27ee77e3e6bbf603d00a2b4fec9dddab7f1d6f9102e63ea7426cd13ac226fc701c7c28d84be6c2
+MISC metadata.xml 655 BLAKE2B 141d8e0009997b21831892bdc2b8765bbfabb21d9f26a4d5af6a5193373e05cccde913fad8320593d2c394ef8af26ec7bc7b13ae89642420363bc4efe3fee3e0 SHA512 98e651be3649ef21f90165756ab53052bee40104a6e819f29e56565436c3ad9ec853ae5a9cbaf9fed911d579c7d16a22a68f328103a2ef23a66ad6e550163d70
diff --git a/dev-php/phar-utils/files/autoload.php b/dev-php/phar-utils/files/autoload.php
new file mode 100644
index 000000000000..44f0299fd7bd
--- /dev/null
+++ b/dev-php/phar-utils/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for symfony-finder and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Seld\\PharUtils\\', __DIR__);
diff --git a/dev-php/phar-utils/metadata.xml b/dev-php/phar-utils/metadata.xml
new file mode 100644
index 000000000000..2cb3579612b7
--- /dev/null
+++ b/dev-php/phar-utils/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ PHAR file format utilities, for when PHP phars you up
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Seldaek/phar-utils</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phar-utils/phar-utils-1.0.0.ebuild b/dev-php/phar-utils/phar-utils-1.0.0.ebuild
new file mode 100644
index 000000000000..6607a9e370ae
--- /dev/null
+++ b/dev-php/phar-utils/phar-utils-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHAR file format utilities, for when PHP phars you up"
+HOMEPAGE="https://github.com/Seldaek/phar-utils"
+SRC_URI="https://github.com/Seldaek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*[phar]
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Seld/PharUtils"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}