summaryrefslogtreecommitdiff
path: root/dev-php/phar-io-manifest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /dev-php/phar-io-manifest
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'dev-php/phar-io-manifest')
-rw-r--r--dev-php/phar-io-manifest/Manifest4
-rw-r--r--dev-php/phar-io-manifest/files/autoload.php62
-rw-r--r--dev-php/phar-io-manifest/metadata.xml11
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild27
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/Manifest b/dev-php/phar-io-manifest/Manifest
new file mode 100644
index 000000000000..0cdafb6e72cf
--- /dev/null
+++ b/dev-php/phar-io-manifest/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 3913 BLAKE2B a3c8a3b75e2b150157892bc8ea168e7c60e5cef95cdee1279579a4b1efd4a4647bb5ec22f272575342d8945674fce048b1a091cd48977cdc77a975668c3a0849 SHA512 d43f3a726eb79ee88e674ac0ec3fb4d175ac0041b96638e4d2a40a47720ebd3a983cd36dd943fff9c0220dda68549361628636e94f595b0601d6eddf2b937fe6
+DIST phar-io-manifest-1.0.1.tar.gz 21403 BLAKE2B 0f18d94d127ec54914cb60756fd3e75c2d13ec593b7101735e385e4515abf4da0f03ef94d0bbbfaee02f348309525504f5e99e150a68b0d0fcd2129ccade4541 SHA512 3e4dd7ddd6de0a9f70595d0d8a6721782d2584526d3d4649cf0338ab36f106798daf4b7dcbf5bd972893a1569b622e4217212e5812b14e4bf3f698504f4d2228
+EBUILD phar-io-manifest-1.0.1.ebuild 690 BLAKE2B b6bd099ec1e2f0a60c2f2290bcfa2a8bdb95e48d6caa396f027a715f2b7a3d527a8e49520e79baac0c3781160819ea864c336e3169877f99a1c01ba7aa7fc253 SHA512 1bd0b6cdb2d85a41191defdf180fac23d4004ad21080553165b4519479b7b810011cf10cd8c0c19881b6eaf5f5290eed9d6b66445933ccdb4b8b1423eb92b692
+MISC metadata.xml 320 BLAKE2B 2a537b76317bec0310e9c6912562d75b512f00dae3ae411aff048a15e7b0986328699427135dedeb990f3f64f3b4b012e139349c5c082a7ba4c6447ce7b68143 SHA512 7ddc7f302bdafae9be276682a0c57125beeb45a9b96afd3fa1662cb699b95c96c36151ab91027e890c33054bd735ae250667292552ea20397587e6f547ad5aa6
diff --git a/dev-php/phar-io-manifest/files/autoload.php b/dev-php/phar-io-manifest/files/autoload.php
new file mode 100644
index 000000000000..f604d8b1f924
--- /dev/null
+++ b/dev-php/phar-io-manifest/files/autoload.php
@@ -0,0 +1,62 @@
+<?php
+
+require_once 'Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ [
+ 'phario\\manifest\\manifestdocumentmapper' => '/ManifestDocumentMapper.php',
+ 'phario\\manifest\\manifestloader' => '/ManifestLoader.php',
+ 'phario\\manifest\\manifestserializer' => '/ManifestSerializer.php',
+ 'phario\\manifest\\exception' => '/exceptions/Exception.php',
+ 'phario\\manifest\\invalidapplicationnameexception' => '/exceptions/InvalidApplicationNameException.php',
+ 'phario\\manifest\\invalidemailexception' => '/exceptions/InvalidEmailException.php',
+ 'phario\\manifest\\invalidurlexception' => '/exceptions/InvalidUrlException.php',
+ 'phario\\manifest\\manifestdocumentexception' => '/exceptions/ManifestDocumentException.php',
+ 'phario\\manifest\\manifestdocumentmapperexception' => '/exceptions/ManifestDocumentMapperException.php',
+ 'phario\\manifest\\manifestelementexception' => '/exceptions/ManifestElementException.php',
+ 'phario\\manifest\\manifestloaderexception' => '/exceptions/ManifestLoaderException.php',
+ 'phario\\manifest\\application' => '/values/Application.php',
+ 'phario\\manifest\\applicationname' => '/values/ApplicationName.php',
+ 'phario\\manifest\\author' => '/values/Author.php',
+ 'phario\\manifest\\authorcollection' => '/values/AuthorCollection.php',
+ 'phario\\manifest\\authorcollectioniterator' => '/values/AuthorCollectionIterator.php',
+ 'phario\\manifest\\bundledcomponent' => '/values/BundledComponent.php',
+ 'phario\\manifest\\bundledcomponentcollection' => '/values/BundledComponentCollection.php',
+ 'phario\\manifest\\bundledcomponentcollectioniterator' => '/values/BundledComponentCollectionIterator.php',
+ 'phario\\manifest\\copyrightinformation' => '/values/CopyrightInformation.php',
+ 'phario\\manifest\\email' => '/values/Email.php',
+ 'phario\\manifest\\extension' => '/values/Extension.php',
+ 'phario\\manifest\\library' => '/values/Library.php',
+ 'phario\\manifest\\license' => '/values/License.php',
+ 'phario\\manifest\\manifest' => '/values/Manifest.php',
+ 'phario\\manifest\\phpextensionrequirement' => '/values/PhpExtensionRequirement.php',
+ 'phario\\manifest\\phpversionrequirement' => '/values/PhpVersionRequirement.php',
+ 'phario\\manifest\\requirement' => '/values/Requirement.php',
+ 'phario\\manifest\\requirementcollection' => '/values/RequirementCollection.php',
+ 'phario\\manifest\\requirementcollectioniterator' => '/values/RequirementCollectionIterator.php',
+ 'phario\\manifest\\type' => '/values/Type.php',
+ 'phario\\manifest\\url' => '/values/Url.php',
+ 'phario\\manifest\\authorelement' => '/xml/AuthorElement.php',
+ 'phario\\manifest\\authorelementcollection' => '/xml/AuthorElementCollection.php',
+ 'phario\\manifest\\bundleselement' => '/xml/BundlesElement.php',
+ 'phario\\manifest\\componentelement' => '/xml/ComponentElement.php',
+ 'phario\\manifest\\componentelementcollection' => '/xml/ComponentElementCollection.php',
+ 'phario\\manifest\\containselement' => '/xml/ContainsElement.php',
+ 'phario\\manifest\\copyrightelement' => '/xml/CopyrightElement.php',
+ 'phario\\manifest\\elementcollection' => '/xml/ElementCollection.php',
+ 'phario\\manifest\\extelement' => '/xml/ExtElement.php',
+ 'phario\\manifest\\extelementcollection' => '/xml/ExtElementCollection.php',
+ 'phario\\manifest\\extensionelement' => '/xml/ExtensionElement.php',
+ 'phario\\manifest\\licenseelement' => '/xml/LicenseElement.php',
+ 'phario\\manifest\\manifestdocument' => '/xml/ManifestDocument.php',
+ 'phario\\manifest\\manifestdocumentloadingexception' => '/xml/ManifestDocumentLoadingException.php',
+ 'phario\\manifest\\manifestelement' => '/xml/ManifestElement.php',
+ 'phario\\manifest\\phpelement' => '/xml/PhpElement.php',
+ 'phario\\manifest\\requireselement' => '/xml/RequiresElement.php',
+ ],
+ __DIR__
+);
+
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PharIo/Version/autoload.php'
+]);
diff --git a/dev-php/phar-io-manifest/metadata.xml b/dev-php/phar-io-manifest/metadata.xml
new file mode 100644
index 000000000000..622fae9de476
--- /dev/null
+++ b/dev-php/phar-io-manifest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phar-io/manifest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
new file mode 100644
index 000000000000..c70be9f4ebe4
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/manifest-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-php/phar-io-version
+ dev-lang/php:*[phar]"
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+ dodoc README.md
+ use examples && dodoc -r examples
+}