summaryrefslogtreecommitdiff
path: root/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild')
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
new file mode 100644
index 000000000000..25f65d07e8d4
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="https://github.com/phar-io/manifest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-php/phar-io-version-3.0.1
+ >=dev-lang/php-7.2:*[phar,xml(-),xmlwriter(-)]"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/manifest-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+
+ cat >> src/autoload.php <<EOF || die "failed to extend autoload.php"
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PharIo/Version/autoload.php'
+]);
+EOF
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ dodoc README.md
+ use examples && dodoc -r examples
+}