summaryrefslogtreecommitdiff
path: root/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild')
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
new file mode 100644
index 000000000000..7287044db582
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/manifest-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-php/phar-io-version-2
+ dev-lang/php:*[phar]"
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+ dodoc README.md
+ use examples && dodoc -r examples
+}