summaryrefslogtreecommitdiff
path: root/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-zmq/pecl-zmq-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-9999.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
new file mode 100644
index 000000000000..0045fcc8b0a7
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3 git-r3
+
+KEYWORDS=""
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}