summaryrefslogtreecommitdiff
path: root/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-zmq/pecl-zmq-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-9999.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
new file mode 100644
index 000000000000..9e61585d5f61
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3 git-r3
+
+KEYWORDS=""
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
+
+src_unpack() {
+ git-r3_src_unpack
+ php-ext-source-r3_src_unpack
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}