summaryrefslogtreecommitdiff
path: root/dev-php/pecl-taint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-taint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-taint')
-rw-r--r--dev-php/pecl-taint/Manifest5
-rw-r--r--dev-php/pecl-taint/metadata.xml11
-rw-r--r--dev-php/pecl-taint/pecl-taint-2.0.2.ebuild19
-rw-r--r--dev-php/pecl-taint/pecl-taint-2.0.4.ebuild19
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-php/pecl-taint/Manifest b/dev-php/pecl-taint/Manifest
new file mode 100644
index 000000000000..85f03a82274e
--- /dev/null
+++ b/dev-php/pecl-taint/Manifest
@@ -0,0 +1,5 @@
+DIST taint-2.0.2.tgz 18550 BLAKE2B 70bd0425ab179c5313108a363b24310ed0c438a208ec15158d8c760cc8e2514b1031554827ced569c71cdb5109634463f75ca583fcc5cad56946947ab569fe25 SHA512 fe1375062f716a32b093942d173cf78024ed457fb5980ec8b50852ca922d8e15ec82696be2478cbbf8b9cd0620be0c2f88b18de55dec4dacec5be664b95c7108
+DIST taint-2.0.4.tgz 18063 BLAKE2B 1ef1d44cc3dac5e25aeeac86b04d491e050174ed9ced1424729b29531917baf0776c8a6d78bc2d7b42bc768ba6744833d08c8df525d5fdd962b590b2d4c2a009 SHA512 d1c265e0fa4293b2aeb0f7413b852e85c6c321c67e31ff8fd51afefd157af4b733dfdf1452f50bcf3b05c1b5f26de9ebabe4ebe862657a05c4b6abc6770c2c7f
+EBUILD pecl-taint-2.0.2.ebuild 425 BLAKE2B 229e8816bd226a259ca73d97a3796cb5f1217fe059333dd47bf961bae498582d04ec1888895610fda229513b8e02f373b36e752330838f0c098ef6ec67e87d83 SHA512 bc62f5828f98be1bbfad72e58aac0a7d6f12bb21fd632b684841231879b0726db19d47cc9d488318e13ffa035863915d5e743976ec7404c54496d5f83988b0b9
+EBUILD pecl-taint-2.0.4.ebuild 432 BLAKE2B 3af9a1e629f986dc10764a5fb1c39cc41862c2998fd88ca51009adf0978f6a26d6343bd1abc8081d487398e1e31172dc238451bc592762900744ec155b61086a SHA512 50d97b6e65260e210bc457a668d9a25766d3496591ca4456fddb87a97e09669d7459c1bbc51043aadc58940feea221383b2ea06a039f4d1d045e33ac5ae51768
+MISC metadata.xml 345 BLAKE2B 1bce954b00c4fe92867211caee4fc891eee89ebea7550eef40e775794fd13b285f3b00e1ad25f5b8c967b946bf3545a661053068a2c077e8051bd30915b55049 SHA512 f6c8ba5b96f05f24c3e2b7245fc72b9ee34ddc61a335081cf50d4e0f9915d3891599ff9e086d52f7d19a44c633d9a880941d8a18c5a583659c410de2086b6717
diff --git a/dev-php/pecl-taint/metadata.xml b/dev-php/pecl-taint/metadata.xml
new file mode 100644
index 000000000000..9199ac2d2e71
--- /dev/null
+++ b/dev-php/pecl-taint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <longdescription lang="en">
+ Extension used for detecting XSS codes(tainted string)
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-php/pecl-taint/pecl-taint-2.0.2.ebuild b/dev-php/pecl-taint/pecl-taint-2.0.2.ebuild
new file mode 100644
index 000000000000..281e7a24dfb8
--- /dev/null
+++ b/dev-php/pecl-taint/pecl-taint-2.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php7-0 php7-1"
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Extension used for detecting XSS code (tainted strings)"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_postinst() {
+ elog 'To enable this extension, add'
+ elog ' taint.enable=1'
+ elog 'to /etc/php/<sapi>-<slot>/ext/taint.ini'
+}
diff --git a/dev-php/pecl-taint/pecl-taint-2.0.4.ebuild b/dev-php/pecl-taint/pecl-taint-2.0.4.ebuild
new file mode 100644
index 000000000000..d040e2ceac50
--- /dev/null
+++ b/dev-php/pecl-taint/pecl-taint-2.0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php7-0 php7-1 php7-2"
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Extension used for detecting XSS code (tainted strings)"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_postinst() {
+ elog 'To enable this extension, add'
+ elog ' taint.enable=1'
+ elog 'to /etc/php/<sapi>-<slot>/ext/taint.ini'
+}