summaryrefslogtreecommitdiff
path: root/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
new file mode 100644
index 000000000000..e493a7b71a86
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+EGIT_REPO_URI="https://git.php.net/repository/pecl/networking/ssh2.git"
+
+inherit php-ext-source-r3 git-r3
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+KEYWORDS=""
+DEPEND=">=net-libs/libssh2-1.2"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-ssh2:0[php_targets_php5-6] )"
+HOMEPAGE="https://pecl.php.net/package/ssh2"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}