summaryrefslogtreecommitdiff
path: root/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild
new file mode 100644
index 000000000000..1d3d6dcf1f0d
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+# Upstream notes say there are errors with gcrypt backend
+DEPEND="net-libs/libssh2[-gcrypt]"
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
+ php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
+
+src_prepare(){
+ if use php_targets_php5-6 ; then
+ local PATCHES=( "${FILESDIR}/0.13-parse_url-fix.patch" )
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}