summaryrefslogtreecommitdiff
path: root/dev-php/pecl-rrd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-php/pecl-rrd
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-php/pecl-rrd')
-rw-r--r--dev-php/pecl-rrd/Manifest4
-rw-r--r--dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch81
-rw-r--r--dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch132
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild58
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild29
5 files changed, 245 insertions, 59 deletions
diff --git a/dev-php/pecl-rrd/Manifest b/dev-php/pecl-rrd/Manifest
index deaeba9088a6..5bcbc9156f1b 100644
--- a/dev-php/pecl-rrd/Manifest
+++ b/dev-php/pecl-rrd/Manifest
@@ -1,3 +1,5 @@
+AUX 2.0.1/0001-arginfo.patch 2714 BLAKE2B 23b597baafd80f10abd922d096b94968b54bb4d3b5682242ad66f85d85dd3ab984d9e3623cd03a4f8c38a8798887ceba62e33c177d3ce8c0ebaf6e3cae99a149 SHA512 01ff4826777e30048dd9db3b9589017a39da6e038a113fdc772e1023c85527af146ee5ad7f79cc91976f7991e1b182e20537df38e94ac28307fc26a6708bb290
+AUX 2.0.1/0002-relax-float-test-result.patch 3214 BLAKE2B 28be00e2e4c85baf8f3da4da764d45e9f5f9a232c49e73c9d4f76a94c9eeb9b265ed56feffe3b19f7a5f314907139446e4b6ec837ceabb4f760c08fa0092202f SHA512 fd18c196df8a9fb36acf7f4f5cfbf048f829c00b08f2ad3c371252adbe9f148082026ce7c2e48126cb089e8820b77db8e19f86fe6e97836eac0eec4ca97a2871
DIST rrd-2.0.1.tgz 18880 BLAKE2B c3fb65e95aece39690085830ec1c43ba173e173591215d6a66145ac71079f8d5ba5b097acd9018c86d2342550001334f8e1c98e22204d94a24aee5cc086295ca SHA512 b6f7173f54fcf49bf014cc6c78263c169cdf53dac66c12f5f88db7e01b49ea74da84a55f61deb25c866e6e2e74275ec48fc4a3d1b46719f66b5b7b7eb000b6b3
-EBUILD pecl-rrd-2.0.1-r3.ebuild 1615 BLAKE2B bc514bf53d9e03ac778a5a91151ca70bf501d671f9de82b4a0f8623a4106df22d549855f7607b15b305a36ced11553b89cff32da206c06bcd2191dd5c4dea437 SHA512 3176ee9520fd9fa7c5748c2dc3c2920ba2ac2a87b303a6cc79e9ae65cd14fd55039201baeb13a08479f06db1cacef9e2bc2718814911b7e1691396b978ae9905
+EBUILD pecl-rrd-2.0.1-r4.ebuild 553 BLAKE2B b7a7c2030a7a8ee0ef20603d94be73a293144ef08b9026fcb365f2a3eca9d9050389cf042b379dadeddb65d62c777b89b4f30f15d3a7db119c37cf981448f052 SHA512 d01b856299b59636fa5a116a94b0a76497a74aadac7bae2149c881880d346dcce02f0dfe8c5f67f74c72602d05adeb0d08dd40c52496a10c4161bf4c41db7dde
MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch b/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch
new file mode 100644
index 000000000000..28496fe19c96
--- /dev/null
+++ b/dev-php/pecl-rrd/files/2.0.1/0001-arginfo.patch
@@ -0,0 +1,81 @@
+--- a/rrd.c 2020/09/23 07:41:40 350617
++++ b/rrd.c 2020/09/23 09:09:08 350618
+@@ -552,6 +552,9 @@
+ ZEND_ARG_INFO(0, file)
+ ZEND_ARG_INFO(0, options)
+ ZEND_END_ARG_INFO()
++
++ZEND_BEGIN_ARG_INFO(arginfo_rrd_void, 0)
++ZEND_END_ARG_INFO()
+ /* }}} */
+
+ /* {{{ */
+@@ -559,7 +562,7 @@
+ PHP_FE(rrd_update, arginfo_rrd_update)
+ PHP_FE(rrd_create, arginfo_rrd_create)
+ PHP_FE(rrd_graph, arginfo_rrd_graph)
+- PHP_FE(rrd_error, NULL)
++ PHP_FE(rrd_error, arginfo_rrd_void)
+ PHP_FE(rrd_fetch, arginfo_rrd_fetch)
+ PHP_FE(rrd_first, arginfo_rrd_first)
+ PHP_FE(rrd_info, arginfo_rrd_info)
+@@ -569,9 +572,9 @@
+ PHP_FE(rrd_tune, arginfo_rrd_tune)
+ PHP_FE(rrd_xport, arginfo_rrd_xport)
+ #ifdef HAVE_RRDC_DISCONNECT
+- PHP_FE(rrdc_disconnect, NULL)
++ PHP_FE(rrdc_disconnect, arginfo_rrd_void)
+ #endif
+- PHP_FE(rrd_version, NULL)
++ PHP_FE(rrd_version, arginfo_rrd_void)
+ PHP_FE_END
+ };
+ /* }}} */
+--- a/rrd_create.c 2020/09/23 07:41:40 350617
++++ b/rrd_create.c 2020/09/23 09:09:08 350618
+@@ -323,10 +323,13 @@
+ ZEND_ARG_INFO(0, description)
+ ZEND_END_ARG_INFO()
+
++ZEND_BEGIN_ARG_INFO_EX(arginfo_rrdcreator_void, 0, 0, 0)
++ZEND_END_ARG_INFO()
++
+ /* class method table */
+ static zend_function_entry rrd_create_methods[] = {
+ PHP_ME(RRDCreator, __construct, arginfo_rrdcreator_construct, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDCreator, save, NULL, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDCreator, save, arginfo_rrdcreator_void, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDCreator, addDataSource, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDCreator, addArchive, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
+ PHP_FE_END
+--- a/rrd_graph.c 2020/09/23 07:41:40 350617
++++ b/rrd_graph.c 2020/09/23 09:09:08 350618
+@@ -140,6 +140,7 @@
+ array_init(&zv_argv);
+
+ ZEND_HASH_FOREACH_KEY_VAL(Z_ARRVAL(obj->zv_arr_options), num_key, zs_key, zv_option_val) {
++ (void)num_key; /* to avoid -Wunused-but-set-variable */
+ smart_string option = {0}; /* one argument option */
+
+ /* option with string key means long option, hence they are used as
+@@ -356,6 +357,9 @@
+ /* }}} */
+
+ /* arguments */
++ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_void, 0, 0, 0)
++ZEND_END_ARG_INFO()
++
+ ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_path, 0, 0, 1)
+ ZEND_ARG_INFO(0, path)
+ ZEND_END_ARG_INFO()
+@@ -367,8 +371,8 @@
+ /* class method table */
+ static zend_function_entry rrd_graph_methods[] = {
+ PHP_ME(RRDGraph, __construct, arginfo_rrd_path, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDGraph, save, NULL, ZEND_ACC_PUBLIC)
+- PHP_ME(RRDGraph, saveVerbose, NULL, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDGraph, save, arginfo_rrd_void, ZEND_ACC_PUBLIC)
++ PHP_ME(RRDGraph, saveVerbose, arginfo_rrd_void, ZEND_ACC_PUBLIC)
+ PHP_ME(RRDGraph, setOptions, arginfo_rrd_options, ZEND_ACC_PUBLIC)
+ PHP_FE_END
+ };
diff --git a/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch b/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch
new file mode 100644
index 000000000000..b4a692fc3f5f
--- /dev/null
+++ b/dev-php/pecl-rrd/files/2.0.1/0002-relax-float-test-result.patch
@@ -0,0 +1,132 @@
+--- a/tests/rrd_010.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_010.phpt 2020/09/23 09:09:08 350618
+@@ -40,11 +40,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920806500]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920806800]=>
+- float(0.033333333333333)
++ float(0.03333333333%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -52,20 +52,20 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.01333333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.01666666666%s)
+ }
+ ["speed2"]=>
+ array(13) {
+ [920804700]=>
+ float(NAN)
+ [920805000]=>
+- float(0.056666666666667)
++ float(0.05666666666%s)
+ [920805300]=>
+ float(0.02)
+ [920805600]=>
+- float(0.0033333333333333)
++ float(0.00333333333%s)
+ [920805900]=>
+ float(0)
+ [920806200]=>
+@@ -73,7 +73,7 @@
+ [920806500]=>
+ float(0)
+ [920806800]=>
+- float(0.066666666666667)
++ float(0.06666666666%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -81,9 +81,9 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.01333333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.01666666666%s)
+ }
+ }
+-}
+\ No newline at end of file
++}
+--- a/tests/rrd_012.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_012.phpt 2020/09/23 09:09:08 350618
+@@ -69,7 +69,7 @@
+ ["rra[1].xff"]=>
+ float(0.5)
+ ["rra[1].cdp_prep[0].value"]=>
+- float(0.026666666666667)
++ float(0.02666666666%s)
+ ["rra[1].cdp_prep[0].unknown_datapoints"]=>
+ int(0)
+ }
+--- a/tests/rrd_017.phpt 2020/09/23 07:41:40 350617
++++ b/tests/rrd_017.phpt 2020/09/23 09:09:08 350618
+@@ -47,11 +47,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920806500]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920806800]=>
+- float(0.033333333333333)
++ float(0.0333333333%s)
+ [920807100]=>
+ float(0.02)
+ [920807400]=>
+@@ -59,9 +59,9 @@
+ [920807700]=>
+ float(0.02)
+ [920808000]=>
+- float(0.013333333333333)
++ float(0.0133333333%s)
+ [920808300]=>
+- float(0.016666666666667)
++ float(0.0166666666%s)
+ }
+ }
+ [1]=>
+@@ -81,11 +81,11 @@
+ [920805900]=>
+ float(0)
+ [920806200]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920806500]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920806800]=>
+- float(33.333333333333)
++ float(33.333333333%s)
+ [920807100]=>
+ float(20)
+ [920807400]=>
+@@ -93,9 +93,9 @@
+ [920807700]=>
+ float(20)
+ [920808000]=>
+- float(13.333333333333)
++ float(13.333333333%s)
+ [920808300]=>
+- float(16.666666666667)
++ float(16.666666666%s)
+ }
+ }
+ }
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
deleted file mode 100644
index 16e4bc484026..000000000000
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-# Define 5.6 here to have the {I,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# But we really only build 7.0
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-DESCRIPTION="RRDtool bindings for PHP"
-LICENSE="BSD"
-SLOT="7"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-2? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-3? ( net-analyzer/rrdtool[graph] )
- php_targets_php7-4? ( net-analyzer/rrdtool[graph] )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- default
- fi
-}
-
-src_configure() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- local PHP_EXT_ECONF_ARGS=()
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- local slot
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Prepare test data
- emake -C tests/data all
- NO_INTERACTION="yes" emake test
- done
- fi
-}
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild
new file mode 100644
index 000000000000..7652ef702136
--- /dev/null
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="RRDtool bindings for PHP"
+LICENSE="BSD"
+SLOT="7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-analyzer/rrdtool[graph(-)]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}" )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Prepare test data
+ emake -C tests/data all
+ NO_INTERACTION="yes" emake test
+ done
+}