summaryrefslogtreecommitdiff
path: root/dev-php/pecl-rrd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/pecl-rrd
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/pecl-rrd')
-rw-r--r--dev-php/pecl-rrd/Manifest2
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild13
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-php/pecl-rrd/Manifest b/dev-php/pecl-rrd/Manifest
index 6b86f96710bc..300a1b0e44e0 100644
--- a/dev-php/pecl-rrd/Manifest
+++ b/dev-php/pecl-rrd/Manifest
@@ -1,5 +1,5 @@
DIST rrd-1.1.3.tgz 19229 BLAKE2B 14bbc97ec52be8f1b99471380cc1408c81056841d932818681868e31badc1a0abefc0d155e594a05492b86b826f21b8dadb0a0dcb43313f48863c64fd8e88a71 SHA512 356264de1b967af0f78e25e3c0afcbec704dd3e49d828e08d21d744d5fcdc46f4cd7f7c118b4e283c20bcaf2a4c29e0ac9437c7f66ca0d260a76fddf7b9d3242
DIST rrd-2.0.1.tgz 18880 BLAKE2B c3fb65e95aece39690085830ec1c43ba173e173591215d6a66145ac71079f8d5ba5b097acd9018c86d2342550001334f8e1c98e22204d94a24aee5cc086295ca SHA512 b6f7173f54fcf49bf014cc6c78263c169cdf53dac66c12f5f88db7e01b49ea74da84a55f61deb25c866e6e2e74275ec48fc4a3d1b46719f66b5b7b7eb000b6b3
EBUILD pecl-rrd-1.1.3-r2.ebuild 792 BLAKE2B 6ea7717d68feaf96d919f4d7e29cf10185588a29a687e068ae768555f340deb8bd93fad6111720248d8fb389fab95f6a8235af50736b54928067cbfd8f8dcdf8 SHA512 b00f02cc0ed6678df78eed5fd0a2417daf2423cf04a524429b1da116babc0baa2d45c90458ec26e71bbb5b843c1a86eee6b34ae410706f5e3fe85e4dd2580dfd
-EBUILD pecl-rrd-2.0.1-r3.ebuild 1366 BLAKE2B cdf8b4986acafb26cb3d768177be1297c6a8436eb37c2e592b580f356bc8c6d6f88e07eae5c73b15b5d1ef97a4fcae417159e64ac9ca0043afb05bc32a79a7df SHA512 2d9abcf47452d5a820bb28ef303756fccbe217422c58c83b2b03f4dcef5b848a0ded367629627147ee785ade44d6a5db7d3698fb8a1a92053ddbd2a67b864f2a
+EBUILD pecl-rrd-2.0.1-r3.ebuild 1615 BLAKE2B bc514bf53d9e03ac778a5a91151ca70bf501d671f9de82b4a0f8623a4106df22d549855f7607b15b305a36ced11553b89cff32da206c06bcd2191dd5c4dea437 SHA512 3176ee9520fd9fa7c5748c2dc3c2920ba2ac2a87b303a6cc79e9ae65cd14fd55039201baeb13a08479f06db1cacef9e2bc2718814911b7e1691396b978ae9905
MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
index 19278bc6f6d8..16e4bc484026 100644
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
@@ -4,12 +4,12 @@
EAPI="7"
# Define 5.6 here to have the {I,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# But we really only build 7.0
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
DESCRIPTION="RRDtool bindings for PHP"
LICENSE="BSD"
@@ -20,11 +20,12 @@ DEPEND="
php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
php_targets_php7-2? ( net-analyzer/rrdtool[graph] )
php_targets_php7-3? ( net-analyzer/rrdtool[graph] )
+ php_targets_php7-4? ( net-analyzer/rrdtool[graph] )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default
@@ -32,21 +33,21 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
local PHP_EXT_ECONF_ARGS=()
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}
src_test() {
local slot
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
# Prepare test data