summaryrefslogtreecommitdiff
path: root/dev-php/pecl-redis/pecl-redis-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /dev-php/pecl-redis/pecl-redis-3.1.2.ebuild
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-3.1.2.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.2.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.2.ebuild
deleted file mode 100644
index 28fa94708b69..000000000000
--- a/dev-php/pecl-redis/pecl-redis-3.1.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="redis"
-USE_PHP="php5-6 php7-0 php7-1"
-DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
-MY_P="${PN/pecl-/}-${PV/_rc/RC}"
-PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
-PHP_EXT_S="${WORKDIR}/${MY_P}"
-
-inherit php-ext-pecl-r3
-
-DESCRIPTION="PHP extension for interfacing with Redis"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="igbinary +session"
-
-DEPEND="igbinary? (
- php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
- php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] )
- php_targets_php7-1? ( dev-php/igbinary[php_targets_php7-1] ) )"
-RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
-
-# The test suite requires network access.
-RESTRICT=test
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-redis
- $(use_enable igbinary redis-igbinary)
- $(use_enable session redis-session)
- )
- php-ext-source-r3_src_configure
-}
-
-src_test(){
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- # Run tests for Redis class
- ${PHPCLI} -d extension=modules/redis.so \
- tests/TestRedis.php \
- --class Redis \
- --host ${PECL_REDIS_HOST} || die 'test suite failed'
- done
-}