summaryrefslogtreecommitdiff
path: root/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-ps/pecl-ps-1.4.1.ebuild')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
new file mode 100644
index 000000000000..e9eca43623d7
--- /dev/null
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="ps"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# Only really build for >=7.0
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for creating PostScript files"
+LICENSE="BSD"
+SLOT="7"
+IUSE="examples"
+
+DEPEND="
+ php_targets_php7-0? ( dev-libs/pslib )
+ php_targets_php7-1? ( dev-libs/pslib )
+ php_targets_php7-2? ( dev-libs/pslib )
+"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
+PHP_EXT_ECONF_ARGS=""
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}