summaryrefslogtreecommitdiff
path: root/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
commit88ebe56470c37b02a044e1091cad6b2df0f3be8f (patch)
treed80b2d9337c01c4a0fe11a2ef9691fc3153ed6d3 /dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
parent4645b6f17f0da81e9fe84081fb126a37102ba153 (diff)
gentoo resync : 11.05.2018
Diffstat (limited to 'dev-php/pecl-propro/pecl-propro-2.1.0.ebuild')
-rw-r--r--dev-php/pecl-propro/pecl-propro-2.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
new file mode 100644
index 000000000000..1c8c99bad920
--- /dev/null
+++ b/dev-php/pecl-propro/pecl-propro-2.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="propro"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable property proxy API for PHP"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}