summaryrefslogtreecommitdiff
path: root/dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild')
-rw-r--r--dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild b/dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..4f22d4dce0c1
--- /dev/null
+++ b/dev-php/pecl-propro/pecl-propro-2.0.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="propro"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="A reusable property proxy API for PHP"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}