summaryrefslogtreecommitdiff
path: root/dev-php/pecl-oauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-php/pecl-oauth
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-php/pecl-oauth')
-rw-r--r--dev-php/pecl-oauth/Manifest4
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild61
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.5.ebuild35
3 files changed, 37 insertions, 63 deletions
diff --git a/dev-php/pecl-oauth/Manifest b/dev-php/pecl-oauth/Manifest
index 96f43adeaaa4..f17d2fbfe6f3 100644
--- a/dev-php/pecl-oauth/Manifest
+++ b/dev-php/pecl-oauth/Manifest
@@ -1,3 +1,3 @@
-DIST oauth-2.0.4.tgz 49359 BLAKE2B d5fb23293fc03f40e2b3a5c5ad51bce1b06a6004e1f20d1563b3db7bb79a71f70bca467348d68b4f6d2393003b4ad23debbe5877192d9e189056e86f9fc00b3e SHA512 269b579f87a9f3f229433c74937f74b9b6df453a6e05f7751ca12fa5f24c9ad62d1ebe5cdb370d33d774a0f2e244c1c685a53226dcb35c0005b5532a00c137d4
-EBUILD pecl-oauth-2.0.4.ebuild 1814 BLAKE2B 5db2f5f7065b30d42e2db2099082f6aa3b1a6c3e8c3802cc75f17729faa6277e21197737077e34921adff7ff0901e9e9bfe831e5509eccf5b6cccc187988706e SHA512 8dd687b3531b19f6f6ca16cb50af9fd38d14c45fcd787f41bdfce288e18ac638054d1042a7c2777b5d2977588a2af0db17ac80a62de55121c05e4ae1d28909fc
+DIST oauth-2.0.5.tgz 49641 BLAKE2B eec258d8dc900c19bea19b0b1db3e1f5b103b65e1298cef0819741181811d98ab86812ab557a3457520bcb6ece48b2b0f081d23897ce06e12b715998cbc1ad2a SHA512 847f8a07aba930d606038a78915ddd9c24aab241d27b844a766e0da3caabf419fd891573524a55b40559a827b1adc1261748efabac5ed1bee45fa770935379ee
+EBUILD pecl-oauth-2.0.5.ebuild 796 BLAKE2B 0920a98c13019a02bff4931a391d23b5c57c35e9bad623a7e2857aa4c5da80ec829514beac42589d486a0ee135f9980eb64641f1322ffec1632c62048077eb29 SHA512 3c88ef0b87789d5478363c4b1f1639d44a8ab86a57a55fcd43523a22d3172fabec015e70e9a77774e2740fb4a81e1e2225b677c075c2d3addeb6c2157502d982
MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild
deleted file mode 100644
index 076b3f695e02..000000000000
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.4.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PHP_EXT_NAME="oauth"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# Really only build for 7.0
-USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
-LICENSE="BSD"
-SLOT="7"
-IUSE="+curl examples"
-
-DEPEND="php_targets_php7-0? ( dev-lang/php:7.0[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-1? ( dev-lang/php:7.1[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-2? ( dev-lang/php:7.2[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-3? ( dev-lang/php:7.3[hash]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-4? (
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6(-)?] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- # Disable tests that depend on header order
- rm "${S}/tests/bug16946.phpt" "${S}/tests/overflow_redir.phpt" || die
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-oauth
- $(use_with curl)
- )
-
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
- php-ext-pecl-r3_src_install
- fi
-}
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.5.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.5.ebuild
new file mode 100644
index 000000000000..18221a56290e
--- /dev/null
+++ b/dev-php/pecl-oauth/pecl-oauth-2.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
+LICENSE="BSD"
+SLOT="7"
+IUSE="+curl examples"
+
+DEPEND="php_targets_php7-2? ( dev-lang/php:7.2[hash(-)]
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+ php_targets_php7-3? ( dev-lang/php:7.3[hash(-)]
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+ php_targets_php7-4? (
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-oauth
+ $(use_with curl)
+ )
+ php-ext-source-r3_src_configure
+}