summaryrefslogtreecommitdiff
path: root/dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild')
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild
new file mode 100644
index 000000000000..c8e9491f1ea5
--- /dev/null
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.1.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="mongodb"
+USE_PHP="php5-6 php7-0"
+DOCS=( README.md )
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="MongoDB database driver for PHP"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl pcre sasl"
+
+RDEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
+ php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
+ >=dev-libs/libbson-1.3.3
+ >=dev-libs/mongo-c-driver-1.3.3[sasl?,ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pcre? ( dev-libs/libpcre )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+# pkgconfig needed if system libraries are used for bson and libmongoc
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-mongodb
+ --with-libbson
+ --with-libmongoc
+ --with-pcre-dir=$(usex pcre)
+ --with-mongodb-sasl=$(usex sasl)
+ )
+ php-ext-source-r3_src_configure
+}