summaryrefslogtreecommitdiff
path: root/dev-php/pecl-mcrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-php/pecl-mcrypt
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-php/pecl-mcrypt')
-rw-r--r--dev-php/pecl-mcrypt/Manifest3
-rw-r--r--dev-php/pecl-mcrypt/metadata.xml12
-rw-r--r--dev-php/pecl-mcrypt/pecl-mcrypt-1.0.1.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-mcrypt/Manifest b/dev-php/pecl-mcrypt/Manifest
new file mode 100644
index 000000000000..31b3bdaf80c8
--- /dev/null
+++ b/dev-php/pecl-mcrypt/Manifest
@@ -0,0 +1,3 @@
+DIST mcrypt-1.0.1.tgz 33782 BLAKE2B db5f89fdbc64c81bd50c92301155527f40b28cd274312565c79327133baa20e14c488f8ad1f87e6ddfd3ced9706ca30f10dc69a08279c82c9ec83fb5f713e826 SHA512 1677202715499a41ac6999089257a059106e58cbac06ca8a7dd2e9edd28be5a4118234dd7468110e9e3d7f9de5d099367848fe84bcd06716ea56645c9015c578
+EBUILD pecl-mcrypt-1.0.1.ebuild 647 BLAKE2B 0003f92a3422b4727eff96664caae6e85fbb6b575cae2b4d3144aef86e3d4e7531c5a4dae828074fa7f988287b7a729c739c0ca8aab6aa744a5f6f657bfcc662 SHA512 e3f99a96ca617d71654571b2fea7454477cce1ea02f429298295e33819fa92429e006e863a7e64a9303357a78333457b42d30b9669f6e812a57bec3595a5cf3d
+MISC metadata.xml 379 BLAKE2B 8e9441d2b290b2055894f11d940424ead756cc408b91b5eecd413f6ed4476de9e025fac57b71d8b92ec655787ba8c6e4ec7565f40c2ab22fc0d96051a56faefb SHA512 f39a4765eca2676d25bd98ad9f17c85e528a31ccc1b06e6327203ddfca981363a5eac870fd4f856f4d11926f689dd5b2ea45297055625e2f7089a7b9aec3f975
diff --git a/dev-php/pecl-mcrypt/metadata.xml b/dev-php/pecl-mcrypt/metadata.xml
new file mode 100644
index 000000000000..1b662aaef98c
--- /dev/null
+++ b/dev-php/pecl-mcrypt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.1.ebuild b/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.1.ebuild
new file mode 100644
index 000000000000..133d25ed4e63
--- /dev/null
+++ b/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="mcrypt"
+USE_PHP="php7-2"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Bindings for the libmcrypt library"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/libmcrypt"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # PHP Warning: Use of undefined constant MCRYPT_CBC - assumed 'MCRYPT_CBC'
+ sed -i '/MODE3/s/MCRYPT_CBC/"MCRYPT_CBC"/g' tests/bug8040.phpt || die
+
+ php-ext-source-r3_src_prepare
+}