summaryrefslogtreecommitdiff
path: root/dev-php/pecl-haru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-haru
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/Manifest3
-rw-r--r--dev-php/pecl-haru/metadata.xml11
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/pecl-haru/Manifest b/dev-php/pecl-haru/Manifest
new file mode 100644
index 000000000000..7beaea865cc9
--- /dev/null
+++ b/dev-php/pecl-haru/Manifest
@@ -0,0 +1,3 @@
+DIST haru-1.0.4.tgz 27538 BLAKE2B 9a070e76c98dc59895d3dea97bdd703fd1bf103ff0f285dc28d5568f74fbf74dc0de76b7ab32ff981505f639037ff67aaad4b0f4732e08f5d3c8264fd7a5bce9 SHA512 75cb8ae200cd41372ac738f5a4ed57607e13d538e2c9a46236dc05b7d0283ed4d152478e12fdff81735a4acd914055ebd58ff937ea0ca0a80056f255217b04c0
+EBUILD pecl-haru-1.0.4-r2.ebuild 574 BLAKE2B 1d8046e2bd66739a89c74e1622b7703983f6603d603f17607015a3ebc8c7d0cfff6047c721d1caed80bb0498c17a2d9ae255f8588a7a8c3096f5dfcba8c3e95a SHA512 1e379a868e2bb4f537e596208a9e47479fe59749a64f4720d4a616f8b441099386ac53e279da90ada9600df3913995e950441cca1bae46f119161e200b3bcaef
+MISC metadata.xml 372 BLAKE2B 3c879fc263286d0ed2e08861b809fde72d9be20dd92199c72ace37d963f588c9336232aecd8b937737850416f7053a2a8420b6f3b4ee9fe72e6b246e3e1e447c SHA512 0451f4f1a39d2b353470f3141ed3d1026d000eee29ea6f74655069993c9d2a0761865df148d1e0dc2239c6be3a0d580702dab49ac24d107df85c8aa0c7b2951c
diff --git a/dev-php/pecl-haru/metadata.xml b/dev-php/pecl-haru/metadata.xml
new file mode 100644
index 000000000000..5092019265f0
--- /dev/null
+++ b/dev-php/pecl-haru/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <longdescription lang="en">These functions allow you to create PDF documents
+ using the Haru Free PDF Library.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..5b9771f7f0fb
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ local PHP_EXT_ECONF_ARGS=(
+ $(usex png '--with-png-dir=/usr' '')
+ $(usex zlib '--with-zlib-dir=/usr' '')
+ )
+
+ php-ext-source-r3_src_configure
+}