summaryrefslogtreecommitdiff
path: root/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild')
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild33
1 files changed, 4 insertions, 29 deletions
diff --git a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
index 43d998a62c33..e39dbd9f0ad1 100644
--- a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
+++ b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
@@ -1,17 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
-# This allows us to depend on the other slot
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
+USE_PHP="php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
-# However, we only really build for 7.x; so redefine it here
-USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
-
KEYWORDS="~amd64 ~x86"
DESCRIPTION="dBase database file access functions"
@@ -20,25 +15,5 @@ SLOT="7"
IUSE=""
DEPEND=""
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-dbase:0[php_targets_php5-6] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- local PHP_EXT_ECONF_ARGS=( )
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=( )