summaryrefslogtreecommitdiff
path: root/dev-php/pecl-bbcode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-bbcode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-bbcode')
-rw-r--r--dev-php/pecl-bbcode/Manifest3
-rw-r--r--dev-php/pecl-bbcode/metadata.xml14
-rw-r--r--dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r2.ebuild32
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/pecl-bbcode/Manifest b/dev-php/pecl-bbcode/Manifest
new file mode 100644
index 000000000000..22483e13d112
--- /dev/null
+++ b/dev-php/pecl-bbcode/Manifest
@@ -0,0 +1,3 @@
+DIST bbcode-1.0.3b1.tgz 47205 BLAKE2B 84552330406fd9ea7aea01ec7473b152e4a418d6847423b0798dc36619a9e8345705f91cda73a36a381c06010a60fb07937f1dd3a9f8b53ae106c32c44ce2886 SHA512 b631beaa062375499fdbf6129c6a7ef8151aa9f2d4e61794c56e48c218abd027b890db7b29a1c768c2d94decdb9a1194277b1da85471014b9cc09597cea7d689
+EBUILD pecl-bbcode-1.0.3_beta1-r2.ebuild 594 BLAKE2B 224416e993275873a294bdc01a45b25bc10bf32ac3f4c88988ee88b3e83673688749b3bd9a1ed308d578f531285f71f8b90a154cbb4aa1438f7fcfba1a28ed9d SHA512 7b0496b40ddcf0075bfc5abb0ec76d01bb13d1ec71ceeedebadf6103af287a266e843bd5d17ec9af8ebe992216248742c681b9bba7ee0b05b2c24ef0e651239d
+MISC metadata.xml 591 BLAKE2B 531553a1250b100c4dd376ec91918c3c310a292b1ea0742b43a95a22f0b5c2fcdcc2ffc311f38e60ab6a1069d30b64319acbb5b164fd9e2bf415622dc75017ba SHA512 da06058cdb7fdb18cd09f42a63e3dc9abc3c6e6dd810bc1e4715e64bc06ebe79bfe2c4711b5e8a675f98e22c1f60b2489ff95d7922f9290ccd085c54f8b369c1
diff --git a/dev-php/pecl-bbcode/metadata.xml b/dev-php/pecl-bbcode/metadata.xml
new file mode 100644
index 000000000000..620cd8dbb05a
--- /dev/null
+++ b/dev-php/pecl-bbcode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+<longdescription>
+This is a quick and efficient BBCode Parsing Library.It provides various tag types,
+high speed one pass parsing, callback system, tag position restriction.
+It will force closing BBCode tags in the good order, and closing terminating tags
+at the end of the string this is in order to ensure HTML Validity in all cases.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r2.ebuild b/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r2.ebuild
new file mode 100644
index 000000000000..eb71563ac56b
--- /dev/null
+++ b/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="bbcode"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( TODO )
+
+USE_PHP="php5-6"
+
+MY_PV="${PV/_beta/b}"
+PECL_PKG_V="${PN/pecl-/}-${MY_PV}"
+PHP_EXT_S="${WORKDIR}/${PECL_PKG_V}"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+SRC_URI="http://pecl.php.net/get/${PECL_PKG_V}.tgz"
+HOMEPAGE="http://pecl.php.net/package/bbcode"
+
+DESCRIPTION="A quick and efficient BBCode Parsing Library"
+LICENSE="PHP-3.01 BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${PHP_EXT_S}"