summaryrefslogtreecommitdiff
path: root/dev-php/pecl-apcu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-php/pecl-apcu
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-php/pecl-apcu')
-rw-r--r--dev-php/pecl-apcu/Manifest2
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index 0c917aaf18b5..5b6bc641e1d0 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1,3 +1,5 @@
DIST apcu-5.1.18.tgz 94668 BLAKE2B c88af867a5f0f3feb550b4b93b83451d972d8f9c2281af8b000b45cb42e2d005f82fe626da8665e0490c79bc378cf9ee5c9a0136d0b490a1155a885bb56fe4f2 SHA512 5e9c5b4540be7abdf2f473d2f8955d8708934a1d6e05cb2c99154cc7ba8a2bbf9afde51769e20f46ef278efd6f60b9172e0864c31e0976b9d3096a337035e7a9
+DIST apcu-5.1.19.tgz 96583 BLAKE2B 330c08a4e557691d0b402111877b3caf56b211256db17cce52a76aeefce7237505eca4ecd71f3770ef3c405182a1604a92cc458cb9bca435b42370fe917e21a7 SHA512 45077e3bd0eac207539e2eafe21968c71f49b8c8920168dbafa87961b041f1d348b6bf1c130104744bc541e1f690854f0a29062e9520db81c04edeee3ef2ed99
EBUILD pecl-apcu-5.1.18.ebuild 1545 BLAKE2B a10003e1378a8f18df700d56ff24ae436da3d0c5024156ee57b9ba2469c99e0a499ab989e64f68409c7d175cdfca16366dcd6fa764b14297e9fec4e8082ccf2f SHA512 a9591492b4f53e90bc29a3cb6c666096732437d7eccbc0843191992a67e1a2aca4a1969a5dba3598d2e40c4451b0b837062ab81cb30c2f4cf763127e440a1854
+EBUILD pecl-apcu-5.1.19.ebuild 1548 BLAKE2B ee3ff6320e07737f0f144085275f5291115181c94431268453cf051d795afd2462c08b99e4a582fc0e505b7ec1ae768f9e202946748f538933599a5f75b5b36a SHA512 9c5219e2a63f1420777ecc5c270d0d7819619717ac1da0736a9c42f85a9b92aa51c5ece6731de2c7bbf42c51cc7f325d70cadcf9b05bac5a610c9235e2c963a8
MISC metadata.xml 540 BLAKE2B a29196911604b13d643db1b09cdae2c578c52f3b3ce92f9d6ae534c6fe9872435a46b15dca79ce8ccf5ca02070f2e694f518c69524ea9380eff8e597d8d4124d SHA512 acd09a9a8e52ddc7e4cde2f048db7f7721fcbe3e24b7b628bf1c14b17381a75b463dede6faa0acfecf8e270693001c30b83758f8ad761979fcbdccb454098e56
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild
new file mode 100644
index 000000000000..2b180c6dc0d5
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.19.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( NOTICE README.md TECHNOTES.txt )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="7"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock-${l} "
+done
+
+IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+ # Remove broken tests from php 7.4 due to trivial output differences
+ if use php_targets_php7-4 ; then
+ php_init_slot_env "php7.4"
+ rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-apcu
+ $(use_enable mmap apcu-mmap)
+ $(use_enable lock-spinlock apcu-spinlocks)
+ )
+ # Broken upstream autoconf test disables if present at all
+ use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r3_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
+ elog
+ elog "If you depend on the apc_* functions,"
+ elog "please install dev-php/pecl-apcu_bc as this extension no longer"
+ elog "provides backwards compatibility."
+}