summaryrefslogtreecommitdiff
path: root/dev-php/maxmind-db-reader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-php/maxmind-db-reader
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-php/maxmind-db-reader')
-rw-r--r--dev-php/maxmind-db-reader/Manifest2
-rw-r--r--dev-php/maxmind-db-reader/maxmind-db-reader-1.4.1.ebuild78
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-php/maxmind-db-reader/Manifest b/dev-php/maxmind-db-reader/Manifest
index a64477068a59..f23b8724e443 100644
--- a/dev-php/maxmind-db-reader/Manifest
+++ b/dev-php/maxmind-db-reader/Manifest
@@ -1,5 +1,3 @@
-DIST MaxMind-DB-Reader-php-1.4.1.tar.gz 19667 BLAKE2B b397eb1bb7fa00c3382c7ee7c019c401d390c88d9bccd7742873445e95cb87d780ac17affe5cd1ec98e6f60d16660784dc5fdb188f8e4d2956df816397a9c251 SHA512 2407f3d1af10830078c9f5ba93ee74761084b06e630242eff0f707b98bdb78e6e87dabc999c36b29780ba9c8c38aec0225700005b66d95b3707bdc06875c6dd5
DIST MaxMind-DB-Reader-php-1.6.0.tar.gz 20898 BLAKE2B cf6922bbd5b2c76fcb9b7a97299f0a73232686bf8facce39355f8a4cc55e98a4d8e64a51eae8427b5f14d6905d4cd85956effa5299cc493bd63708cf52ab30d0 SHA512 e8c0ccf2cfcedf7527b4e3f858d2ed0e70add60692fff4a65f08e5cb885516b7c2a3ceaa3c21713369cd8ffca2b671d764063236de1d729cfc5173f7d5dd4607
-EBUILD maxmind-db-reader-1.4.1.ebuild 2225 BLAKE2B 3281f8568667326e0c8a1c87e63a0f637fd275c4eeea540982d9c1a5f9a0095ce1eb55889deb6ae643d4b2e3bc5a997b59ba7108e1d2b86065ac8c9b5cb5fc51 SHA512 340b443f5205ec325f72fe24d8e8eb77869c2f890967ae6f1f7036a402dd10b6b2620ab1f11a46fff7dba9cc919d8b27298fc27d81bbce59bfd9aacce80cfb18
EBUILD maxmind-db-reader-1.6.0.ebuild 2218 BLAKE2B dca404bcaa496d72cce3bd8055728bdf5f69a6028dd9afeb3c358affa5636a745e36afa42a2eb505c96781bbc0d00535c4df197b4deffb899161a03b76fcd131 SHA512 8243d5a307ac4d3be45dc60c064a9285fbeafb74b847f75152863d9c97393f41b3268c7eec89725beae525435abfaa94a540a3ec04272b92136698050e4b7b54
MISC metadata.xml 585 BLAKE2B 0b6a50c15e2fe822a2a3cb52b7fec01677d4fd8601f9b3d0fbdaffedb951edda038d721bf4fb10ed49c3e87823115069be53495630ed2472c982084256c9d1eb SHA512 ec754283b76dde98c10ae1bbd0c11e24e53162d4829e3d32ca9c32b9dbfdef4df0494ba2fccdc0ba1c05c9aa58086c5064124daff69db00372915c530089b2e9
diff --git a/dev-php/maxmind-db-reader/maxmind-db-reader-1.4.1.ebuild b/dev-php/maxmind-db-reader/maxmind-db-reader-1.4.1.ebuild
deleted file mode 100644
index ebefd8c16abb..000000000000
--- a/dev-php/maxmind-db-reader/maxmind-db-reader-1.4.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-MY_PN="MaxMind-DB-Reader-php"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-PHP_EXT_S="${S}/ext"
-PHP_EXT_NAME="maxminddb"
-PHP_EXT_OPTIONAL_USE="extension"
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-
-inherit php-ext-source-r3
-
-DESCRIPTION="PHP reader for the MaxMind database format"
-HOMEPAGE="https://github.com/maxmind/MaxMind-DB-Reader-php"
-SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="extension test"
-RESTRICT="!test? ( test )"
-
-DEPEND="extension? ( dev-libs/libmaxminddb )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # We need to call eapply_user ourselves, because it may be skipped
- # if either the "extension" USE flag is not set, or if the user's
- # PHP_TARGETS is essentially empty. In the latter case, the eclass
- # src_prepare does nothing. We only call the eclass phase conditionally
- # because the correct version of e.g. "phpize" may not be there
- # unless USE=extension is set.
- if use extension ; then
- php-ext-source-r3_src_prepare
- else
- default
- fi
-}
-
-src_configure() {
- # The eclass phase will try to run the ./configure script even if it
- # doesn't exist (in contrast to the default src_configure), so we
- # need to skip it if the eclass src_prepare (that creates said
- # script) is not run.
- use extension && php-ext-source-r3_src_configure
-}
-
-src_compile() {
- # Avoids the same problem as in src_configure.
- use extension && php-ext-source-r3_src_compile
-}
-
-src_install() {
- dodoc CHANGELOG.md README.md
- insinto /usr/share/php
- doins -r src/MaxMind
- insinto /usr/share/php/MaxMind/Db
- doins autoload.php
-
- use extension && php-ext-source-r3_src_install
-}
-
-src_test() {
- # The PHP API has its own set of tests that isn't shipped with the
- # release tarballs at the moment (github issues 55).
- use extension && php-ext-source-r3_src_test
-}
-
-pkg_postinst() {
- elog "${PN} has been installed in /usr/share/php/MaxMind/Db/."
- elog "To use it in a script, require('MaxMind/Db/autoload.php'),"
- elog "and then most of the examples in the documentation should"
- elog "work without further modification."
-}