summaryrefslogtreecommitdiff
path: root/dev-php/maxmind-db-reader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/maxmind-db-reader
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/maxmind-db-reader')
-rw-r--r--dev-php/maxmind-db-reader/Manifest6
-rw-r--r--dev-php/maxmind-db-reader/files/autoload.php6
-rw-r--r--dev-php/maxmind-db-reader/maxmind-db-reader-1.2.0.ebuild76
-rw-r--r--dev-php/maxmind-db-reader/maxmind-db-reader-1.3.0.ebuild77
-rw-r--r--dev-php/maxmind-db-reader/metadata.xml16
5 files changed, 181 insertions, 0 deletions
diff --git a/dev-php/maxmind-db-reader/Manifest b/dev-php/maxmind-db-reader/Manifest
new file mode 100644
index 000000000000..4490f781faa4
--- /dev/null
+++ b/dev-php/maxmind-db-reader/Manifest
@@ -0,0 +1,6 @@
+AUX autoload.php 199 BLAKE2B 617ed826e95ec3cd03a8686cb3f2ffecc2eee748ccde58f0caf0d89f71187235cad969694c1f7a5fc7e16e1fc53178bf26dc3e7515b13fa264a639cc9fa2e968 SHA512 bb53c3edbab856787432d085f35af4b0388a46489ad910bce4d2e070537b5b1652da6ed7260fa5b1c0fb7f808c5e8a66b9fce0282bc0d62f3e80d1eb2284a905
+DIST MaxMind-DB-Reader-php-1.2.0.tar.gz 17488 BLAKE2B 2a511f84091ade374eb5b9a975fa6dafe75d69c4c057113790492840acfb9b8e50137bf4927814d8d77b2e17f4e0a7fe1ffda511f7c599a604bc69d4f38af406 SHA512 2965c5348ec787e503c04322961b00fe7806cd95c5f711efd9833adc0acb21f0c40cab1983868f8ea0bb4e8576186d83e1e1913b203aab999f3870ea298a9b2a
+DIST MaxMind-DB-Reader-php-1.3.0.tar.gz 18573 BLAKE2B 6f093b4343438d37a44639dd47d4c149bcfdd351b9fe68eb19c1b739a28e7c7605728e47471cc7d5d257d56df5da37b5ffd32c275cb705befe9e6d60a137ac46 SHA512 480fb38122d1700b18bb0b85d8062397ddc7f003897829f3533901c12a409d76eea9d499ffc0fdd1bfaf4d35b954a30606a053b78e787eda27771995e2a1800b
+EBUILD maxmind-db-reader-1.2.0.ebuild 2219 BLAKE2B 60b3a8de3e439e2ae603c49f88bb87f56fcbb052d7a41a0dda046f031e1e6151512f38f9eb86ef4e5274969d5d850a952aa103effba739125b1dfaa45356bc7c SHA512 657716fbf85bb2502230786d10488386d0b89ded10c2981cec1e211422dbcd5ace29182ff0b537786408c088e5c1a61ecbeb2c8d15bdd33e91823cac21111c46
+EBUILD maxmind-db-reader-1.3.0.ebuild 2160 BLAKE2B b73d6b15b781e04c5f23ff5c776e03b761695074dc19a7b74b97f6ae09d273ec53854a9c7ba6af0ecb2b07c9dd885f01aa95b1d389fc145a3d8b5e20b373cd5a SHA512 2232a93f07adf6dae4627c6332e7fd011aa776f1114fc10a987508787b4fc8bff6d3893f973281652754d7f305fb14da9ca66265c0706b5ed840417f4b60114a
+MISC metadata.xml 472 BLAKE2B eafb00cbc65f3b5363ee77c111deaab80e04072ff4669de2ee80a669b1c81f72e8dfb567de682c4b2b5597d731f1bd4480a73e0b9f3b1ee32e02b1f72ced1180 SHA512 7522517bc559e5309dce0bfa525c80f0d00ca57f03d7a6c771fc1ac20281c09efb142bfdafd56633edfa3e2a878943d6bd3c16ea3f93f0b5ca8ba11a5f28cf8d
diff --git a/dev-php/maxmind-db-reader/files/autoload.php b/dev-php/maxmind-db-reader/files/autoload.php
new file mode 100644
index 000000000000..45e8c2dfba31
--- /dev/null
+++ b/dev-php/maxmind-db-reader/files/autoload.php
@@ -0,0 +1,6 @@
+<?php
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('MaxMind\\Db\\', __DIR__);
diff --git a/dev-php/maxmind-db-reader/maxmind-db-reader-1.2.0.ebuild b/dev-php/maxmind-db-reader/maxmind-db-reader-1.2.0.ebuild
new file mode 100644
index 000000000000..344af7938327
--- /dev/null
+++ b/dev-php/maxmind-db-reader/maxmind-db-reader-1.2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="MaxMind-DB-Reader-php"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+PHP_EXT_S="${S}/ext"
+PHP_EXT_NAME="maxminddb"
+PHP_EXT_OPTIONAL_USE="extension"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="PHP reader for the MaxMind database format"
+HOMEPAGE="https://github.com/maxmind/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="extension test"
+
+COMMON_DEPEND="extension? ( dev-libs/libmaxminddb )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ dev-php/fedora-autoloader"
+
+src_prepare(){
+ # We need to call eapply_user ourselves, because it may be skipped
+ # if either the "extension" USE flag is not set, or if the user's
+ # PHP_TARGETS is essentially empty. In the latter case, the eclass
+ # src_prepare does nothing. We only call the eclass phase conditionally
+ # because the correct version of e.g. "phpize" may not be there
+ # unless USE=extension is set.
+ eapply_user
+ use extension && php-ext-source-r3_src_prepare
+}
+
+src_configure() {
+ # The eclass phase will try to run the ./configure script even if it
+ # doesn't exist (in contrast to the default src_configure), so we
+ # need to skip it if the eclass src_prepare (that creates said
+ # script) is not run.
+ use extension && php-ext-source-r3_src_configure
+}
+
+src_compile() {
+ # Avoids the same problem as in src_configure.
+ use extension && php-ext-source-r3_src_compile
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md
+ insinto /usr/share/php
+ doins -r src/MaxMind
+ insinto /usr/share/php/MaxMind/Db
+ doins "${FILESDIR}/autoload.php"
+
+ use extension && php-ext-source-r3_src_install
+}
+
+src_test() {
+ # The PHP API has its own set of tests that isn't shipped with the
+ # release tarballs at the moment (github issues 55).
+ use extension && php-ext-source-r3_src_test
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/MaxMind/Db/."
+ elog "To use it in a script, require('MaxMind/Db/autoload.php'),"
+ elog "and then most of the examples in the documentation should"
+ elog "work without further modification."
+}
diff --git a/dev-php/maxmind-db-reader/maxmind-db-reader-1.3.0.ebuild b/dev-php/maxmind-db-reader/maxmind-db-reader-1.3.0.ebuild
new file mode 100644
index 000000000000..7d53d3fc64d6
--- /dev/null
+++ b/dev-php/maxmind-db-reader/maxmind-db-reader-1.3.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="MaxMind-DB-Reader-php"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+PHP_EXT_S="${S}/ext"
+PHP_EXT_NAME="maxminddb"
+PHP_EXT_OPTIONAL_USE="extension"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="PHP reader for the MaxMind database format"
+HOMEPAGE="https://github.com/maxmind/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="extension test"
+
+DEPEND="extension? ( dev-libs/libmaxminddb )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ # We need to call eapply_user ourselves, because it may be skipped
+ # if either the "extension" USE flag is not set, or if the user's
+ # PHP_TARGETS is essentially empty. In the latter case, the eclass
+ # src_prepare does nothing. We only call the eclass phase conditionally
+ # because the correct version of e.g. "phpize" may not be there
+ # unless USE=extension is set.
+ if use extension ; then
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_configure() {
+ # The eclass phase will try to run the ./configure script even if it
+ # doesn't exist (in contrast to the default src_configure), so we
+ # need to skip it if the eclass src_prepare (that creates said
+ # script) is not run.
+ use extension && php-ext-source-r3_src_configure
+}
+
+src_compile() {
+ # Avoids the same problem as in src_configure.
+ use extension && php-ext-source-r3_src_compile
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md
+ insinto /usr/share/php
+ doins -r src/MaxMind
+ insinto /usr/share/php/MaxMind/Db
+ doins autoload.php
+
+ use extension && php-ext-source-r3_src_install
+}
+
+src_test() {
+ # The PHP API has its own set of tests that isn't shipped with the
+ # release tarballs at the moment (github issues 55).
+ use extension && php-ext-source-r3_src_test
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/MaxMind/Db/."
+ elog "To use it in a script, require('MaxMind/Db/autoload.php'),"
+ elog "and then most of the examples in the documentation should"
+ elog "work without further modification."
+}
diff --git a/dev-php/maxmind-db-reader/metadata.xml b/dev-php/maxmind-db-reader/metadata.xml
new file mode 100644
index 000000000000..c6051cdbefb0
--- /dev/null
+++ b/dev-php/maxmind-db-reader/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <use>
+ <flag name="extension">
+ Build the C extension that uses <pkg>dev-libs/libmaxminddb</pkg>
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">maxmind/MaxMind-DB-Reader-php</remote-id>
+ </upstream>
+</pkgmetadata>