summaryrefslogtreecommitdiff
path: root/dev-php/jsonlint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/jsonlint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/jsonlint')
-rw-r--r--dev-php/jsonlint/Manifest4
-rw-r--r--dev-php/jsonlint/files/autoload.php8
-rw-r--r--dev-php/jsonlint/jsonlint-1.6.0.ebuild40
-rw-r--r--dev-php/jsonlint/metadata.xml21
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-php/jsonlint/Manifest b/dev-php/jsonlint/Manifest
new file mode 100644
index 000000000000..6cdb6e316da5
--- /dev/null
+++ b/dev-php/jsonlint/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 262 BLAKE2B 0394eabe0e8bc08b09cc637e514aa49dee2b83b9c424f0d767a67f75024a86a20bbe63d30fce00cb17b69ee3bd6c74cf310e16a004720fb25aad1e1c65ba82b9 SHA512 476263a08ab0137aed1bb71446f1a66a618247f9095b138b958464f4f47faf775f4bb2ecbe87efa34ff56fb386351e3a3de0dafdf7367c461f0db0717ae5d46e
+DIST jsonlint-1.6.0.tar.gz 11327 BLAKE2B 481744188c6aa8a3135fc76c1026fce75df9ceaf939db9cb88f323afae27bf5041a56d3a63618ef497dc1e8f0606a8b8c24651fab566bb421d12d0ac5853ad15 SHA512 16538781807a4ca73de83e7be69d0fc2b530dd9b25f2b9a2ee3f1156dd5ebccb79e9489b873f307718ca2da658a1ae7cef5144adb32f2d1e5c34bd192d496c79
+EBUILD jsonlint-1.6.0.ebuild 857 BLAKE2B e04940bacd72c2534c1dc05a5d7b98176cde6c7ab4a4a099bd7017d92aa8c8c0054a3c9ffe1941878cc73458c4693e5ff92843612d236c324231310688035c3a SHA512 b83f0b8899284fca3ab096f1a8d8ef167c654156cc96e7dc12e927595c0eb0567d62c3cf9e3539e8fa42311b31a6870ecba2f9d4ec6f0c33b3c6d50c795f11a8
+MISC metadata.xml 653 BLAKE2B b01de68933db99cf59ed9e8ace9af6ba3c8a5948e2478c2361b2a52beb4f617d7fc23adb6eca4d76b162648aa4082a3881c61ad0dca6e02fc9c044ae7740046c SHA512 110ede45bbe6869e8a5831d5fbd2863e69bcd03e179e249efa2b2226c48e47a88569417196dc78f14d7a769d1611b8358839ba354da3dfae05b0a4f6b5c28664
diff --git a/dev-php/jsonlint/files/autoload.php b/dev-php/jsonlint/files/autoload.php
new file mode 100644
index 000000000000..48ac68d82ab1
--- /dev/null
+++ b/dev-php/jsonlint/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for dev-php/jsonlint and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Seld\\JsonLint\\', __DIR__);
diff --git a/dev-php/jsonlint/jsonlint-1.6.0.ebuild b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
new file mode 100644
index 000000000000..ea1e8f975dc1
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
+ dodoc README.mdown
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}
diff --git a/dev-php/jsonlint/metadata.xml b/dev-php/jsonlint/metadata.xml
new file mode 100644
index 000000000000..fec382ce7ecc
--- /dev/null
+++ b/dev-php/jsonlint/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Json linter, port of the JavaScript jsonlint library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Seldaek/jsonlint</remote-id>
+ </upstream>
+</pkgmetadata>