summaryrefslogtreecommitdiff
path: root/dev-php/json-schema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/json-schema
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/json-schema')
-rw-r--r--dev-php/json-schema/Manifest4
-rw-r--r--dev-php/json-schema/files/autoload.php10
-rw-r--r--dev-php/json-schema/json-schema-4.1.0.ebuild40
-rw-r--r--dev-php/json-schema/metadata.xml22
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-php/json-schema/Manifest b/dev-php/json-schema/Manifest
new file mode 100644
index 000000000000..2c1275b8eceb
--- /dev/null
+++ b/dev-php/json-schema/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 272 BLAKE2B 35cf5eb6efc11395c45a12a98d2882bc249b4496cba7b1ceba2abbdfa5dbec43a782e1034701f72e12d586aa80460fa87f0623f497f0da33cd8aaff7948d7370 SHA512 d5b970d485d198c855dcebe4c04adf37d7aaa118d7546c3b6d73944809c69ed18436568e33f847329a8027220f735cd5752ef5019bf8dfad40a740d94d02733c
+DIST json-schema-4.1.0.tar.gz 24772 BLAKE2B 181c584c11113c2e0bb7b2f19ef40ae588e470169a4498a47fbd3fcae60d7bb1bb21ac4ab82ce295e487098719fca9004090142d992a296a1b5599fb909b0171 SHA512 5c6bda8c34012bc20d9bf604a6183d50f451327bded70d94415450d2b3cc8e7f6f416ddd8b13db0aeb487fe031fe3185aebd9c97e4c1f79c866dcbc3463f64d0
+EBUILD json-schema-4.1.0.ebuild 830 BLAKE2B 971c1161efe1a08fdf902496d278d712f449d0a86e5999768a91460da21a2f0b150fa14aea2d560111963a049859db3f4eeeb9c4097435fcc5b9775f3b18c6aa SHA512 f8bb9a1e53d8048a0b500069fdfa389eb0b12a6cb416791e45b34e0de1d66e5d17c3d5ae5c059936e3e6412c1fdddd6dd27723e1d46feacf2e8b8a309ae11f74
+MISC metadata.xml 681 BLAKE2B 7c94639852b0bb93de2ce1d05e53917d4fb893b503ac71f15b39233fc95a67ee469a53f175cd470b6f1f510e4f943839c848ae89ad74d3155c420740102c1185 SHA512 85ad81e521ac9eec7fcf4a8a162e412e97e29c30ed22048258a0a7a00b7f77c559544b033938570ebe64ce34ecd61d48dd20648751872d69b98740e791178845
diff --git a/dev-php/json-schema/files/autoload.php b/dev-php/json-schema/files/autoload.php
new file mode 100644
index 000000000000..c8a6c8a8b715
--- /dev/null
+++ b/dev-php/json-schema/files/autoload.php
@@ -0,0 +1,10 @@
+<?php
+/**
+ * Autoloader for justinrainbow/json-schema and its dependencies
+ */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('JsonSchema\\', __DIR__);
diff --git a/dev-php/json-schema/json-schema-4.1.0.ebuild b/dev-php/json-schema/json-schema-4.1.0.ebuild
new file mode 100644
index 000000000000..9412e627e0ea
--- /dev/null
+++ b/dev-php/json-schema/json-schema-4.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Tests are not in the release tarball
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/JsonSchema"
+ doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}
diff --git a/dev-php/json-schema/metadata.xml b/dev-php/json-schema/metadata.xml
new file mode 100644
index 000000000000..dff9620c7508
--- /dev/null
+++ b/dev-php/json-schema/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A PHP library for validating JSON structures against a given
+ schema.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">justinrainbow/json-schema</remote-id>
+ </upstream>
+</pkgmetadata>