summaryrefslogtreecommitdiff
path: root/dev-php/json-schema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/json-schema
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/json-schema')
-rw-r--r--dev-php/json-schema/Manifest4
-rw-r--r--dev-php/json-schema/files/autoload.php10
-rw-r--r--dev-php/json-schema/json-schema-4.1.0.ebuild40
-rw-r--r--dev-php/json-schema/metadata.xml21
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/json-schema/Manifest b/dev-php/json-schema/Manifest
new file mode 100644
index 000000000000..d7ebe63319ab
--- /dev/null
+++ b/dev-php/json-schema/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 272 SHA256 a4f934765bd4097b07e8c6c38f498bc52d3d2ec70a901417b04ea9f422b89785 SHA512 d5b970d485d198c855dcebe4c04adf37d7aaa118d7546c3b6d73944809c69ed18436568e33f847329a8027220f735cd5752ef5019bf8dfad40a740d94d02733c WHIRLPOOL 7fb5e942a4c3c8636c94e75505249005cb06ed8b375b3f63ab637b67b4c96aa63309521408a1cb6768237850394581733edf3766cf458393c50d04f375356191
+DIST json-schema-4.1.0.tar.gz 24772 SHA256 8470ef4f5b55018102911a2403184215e5c3459ceb6bf3ce9bdb8cceed469284 SHA512 5c6bda8c34012bc20d9bf604a6183d50f451327bded70d94415450d2b3cc8e7f6f416ddd8b13db0aeb487fe031fe3185aebd9c97e4c1f79c866dcbc3463f64d0 WHIRLPOOL a6b9db1b0838f7887b3408eba72655d7108ffd9198a7ca15f89538a743b36ac167b4334a9de902eca61d751a060fb373bab1083502c4b198142a54cdd560f269
+EBUILD json-schema-4.1.0.ebuild 830 SHA256 7ab3b83d1027a2a1a2d5bc1e5666eb46886deea0cfd72bcdecb0c1d6561be111 SHA512 f8bb9a1e53d8048a0b500069fdfa389eb0b12a6cb416791e45b34e0de1d66e5d17c3d5ae5c059936e3e6412c1fdddd6dd27723e1d46feacf2e8b8a309ae11f74 WHIRLPOOL be56f3bccbe79fd8546ca35dd5c53b1fe8b8a98292f0cfcaa1d053493d009858cf156a7767c6ab9be29441d0dfdfbb8dc5f2b86617c1d56645ef0fce1ced1322
+MISC metadata.xml 683 SHA256 22d03ded1469e97a2e047a5d03fea58cf33da5ea7f311ac9cc906000a6454ce5 SHA512 e1531ae60e99346cc913393e7272a4f1b68fbaed8af2bd19a275982dafd2f0d5e0304e639a1a8dd48744193d3416da121c6e4640381fed151bfd370d8a015918 WHIRLPOOL 3be2281c4c1800753bf5ef23d8c3c7b55529c94ef2014e6bd3ee8e19fc4b92522c94b851d71a08996fed3637f837f54f50854fec991da00b9e59f87ff15f4495
diff --git a/dev-php/json-schema/files/autoload.php b/dev-php/json-schema/files/autoload.php
new file mode 100644
index 000000000000..c8a6c8a8b715
--- /dev/null
+++ b/dev-php/json-schema/files/autoload.php
@@ -0,0 +1,10 @@
+<?php
+/**
+ * Autoloader for justinrainbow/json-schema and its dependencies
+ */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('JsonSchema\\', __DIR__);
diff --git a/dev-php/json-schema/json-schema-4.1.0.ebuild b/dev-php/json-schema/json-schema-4.1.0.ebuild
new file mode 100644
index 000000000000..9412e627e0ea
--- /dev/null
+++ b/dev-php/json-schema/json-schema-4.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# Tests are not in the release tarball
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/JsonSchema"
+ doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}
diff --git a/dev-php/json-schema/metadata.xml b/dev-php/json-schema/metadata.xml
new file mode 100644
index 000000000000..43b623ea5479
--- /dev/null
+++ b/dev-php/json-schema/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A PHP Implementation for validating JSON Structures against a given Schema.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">justinrainbow/json-schema</remote-id>
+ </upstream>
+</pkgmetadata>