summaryrefslogtreecommitdiff
path: root/dev-php/igbinary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/igbinary
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/igbinary')
-rw-r--r--dev-php/igbinary/Manifest5
-rw-r--r--dev-php/igbinary/igbinary-2.0.5.ebuild26
-rw-r--r--dev-php/igbinary/igbinary-2.0.6.ebuild26
-rw-r--r--dev-php/igbinary/metadata.xml11
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-php/igbinary/Manifest b/dev-php/igbinary/Manifest
new file mode 100644
index 000000000000..d088b7a9bd0b
--- /dev/null
+++ b/dev-php/igbinary/Manifest
@@ -0,0 +1,5 @@
+DIST igbinary-2.0.5.tar.gz 183869 BLAKE2B 8bb56ff0213c77dbc17cf65962e23579935b2330ca2107b8e6e00461a486e60df4209c375e9f74d17bb0a745136fa776233b41cfc51ffb5e1dc1c8fdb4a8bbf2 SHA512 e0abae97b5a0c9ab30ea00a490294f18f91b66b728a05186167e15c0a631d4de82b8a24d370a0d58cf5552adde68dd1b3fe56e877d382fbbdac02cfc18e49063
+DIST igbinary-2.0.6.tar.gz 184889 BLAKE2B 7c07dc7b766ea395137c2cfffab6329f6fe5fc7e8ffb712474ef9c945319364b20ba4f8735aa776bc15b94c2cd815bba5c1a8b7c25c9715d706a6773f80082d8 SHA512 c9f76aedcfb5aace6b8a3c064410b099bf4563d99115ebfeb9c53a3dd18a48e5c44b99a04a2a75f5d114aa5a6d9030b6f2242502c6b3c9d273a6936f9fa410e6
+EBUILD igbinary-2.0.5.ebuild 584 BLAKE2B 6c928e2f63bc4af2255092a71c39e916db15b1ece4f1aa171719ad31a744231aedc099e938a66eaca37c9b936d607e060fb1ac19e0519c186c6988ae11a8ed23 SHA512 ae02b0f4099d8f65f796d60ccb11c8aa05b7d7218b6b7eae137229f5269d6168a0caea1e5215795cb12a1379442b7e7ac3ffff3dcb391154951a5da643aa285a
+EBUILD igbinary-2.0.6.ebuild 586 BLAKE2B 06ab30e3024877c2be0acb740bdedb378b8ffe84f3c03888a1bf4363b27faa9ce2fb30143dd9c1d33ad6dd90d2bb7ed9a13257a6179dd5cddd0a0aa9a4ab2a93 SHA512 b79d6efcca26e1d0d9f55af8bbc1e7eed3309dfcb081878a70f54fcf610065ae41ccecf0da72e2ecb61b36bbfd25d97848c1b51df9eeb977a003d71bb9e78f25
+MISC metadata.xml 331 BLAKE2B 4187300236aa128879679c7cb4a8ddfa19dfd512a76466e835224c30323f2fafd55189228bdced507ababd5b90f561f6bb44c1554392eb0682b6ba5c7a20b681 SHA512 86f467f549b36915940e45a4e151742f2925293106dd3da2958e6153aaa8fed378b2eb563bf69da0d38101409858a4abe308f608bd94de6b4517daf9da092405
diff --git a/dev-php/igbinary/igbinary-2.0.5.ebuild b/dev-php/igbinary/igbinary-2.0.5.ebuild
new file mode 100644
index 000000000000..7bb040ccb2de
--- /dev/null
+++ b/dev-php/igbinary/igbinary-2.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS NEWS README.md )
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-source-r3
+
+KEYWORDS="amd64 ~arm x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
diff --git a/dev-php/igbinary/igbinary-2.0.6.ebuild b/dev-php/igbinary/igbinary-2.0.6.ebuild
new file mode 100644
index 000000000000..7421e044d58d
--- /dev/null
+++ b/dev-php/igbinary/igbinary-2.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS NEWS README.md )
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~arm ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/${PN}/${PN}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
diff --git a/dev-php/igbinary/metadata.xml b/dev-php/igbinary/metadata.xml
new file mode 100644
index 000000000000..aa78522f3ec0
--- /dev/null
+++ b/dev-php/igbinary/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">igbinary/igbinary</remote-id>
+ </upstream>
+</pkgmetadata>