summaryrefslogtreecommitdiff
path: root/dev-php/fedora-autoloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/fedora-autoloader
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/fedora-autoloader')
-rw-r--r--dev-php/fedora-autoloader/Manifest5
-rw-r--r--dev-php/fedora-autoloader/fedora-autoloader-0.2.1.ebuild31
-rw-r--r--dev-php/fedora-autoloader/fedora-autoloader-1.0.0.ebuild34
-rw-r--r--dev-php/fedora-autoloader/metadata.xml22
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-php/fedora-autoloader/Manifest b/dev-php/fedora-autoloader/Manifest
new file mode 100644
index 000000000000..d9505933d4ab
--- /dev/null
+++ b/dev-php/fedora-autoloader/Manifest
@@ -0,0 +1,5 @@
+DIST fedora-autoloader-0.2.1.tar.gz 7634 BLAKE2B e2827ac332a7b50f94383a11b33f25625d67984491fc46dce6ad01d6e4b986c489062464d09ff5ed32f29c2d623ff9d59579fc007eceb1279f660695feea72a0 SHA512 81501dbc0668c1cc6d6fb030e0d9ee91d31db8fa32b3348a0215dbf20a3ef1d41bc398124e1d7f0c1d5ffa8fce8c33e60a3182eaba6ba740d78b4a7f6db2aea8
+DIST fedora-autoloader-1.0.0.tar.gz 8504 BLAKE2B ada69f3f3126b2c233b0ab933e52468d8303dbaacfc27364f490ce7b093043f92913ecc55180b460828573f0f204f5e7f4d10b3149ef6f5b3cee1d645fa6ac58 SHA512 a8e3330d961a9415a817d41ad9feb91018aa398607a2adce1f8386d491581773226f6819ac3d90827344898fbbdb32c0881af3f122efdad021f7ce70a07cc66e
+EBUILD fedora-autoloader-0.2.1.ebuild 698 BLAKE2B f1d6b9de6d5af4de150e2a08b31183bbee4c92628b5b9e612561c32d64cb51a4a81458799f0820ed6e0671cc939ed206841370a8b165b392d7e1ae1a9f123bbd SHA512 7732032bab321dfcd732600dae515f23dec33348a709a4fdc9cf3b6f503db5e91473758aef682c5d96f486dffca4751be86526b1fb53d39b223aa6fccc840eb9
+EBUILD fedora-autoloader-1.0.0.ebuild 725 BLAKE2B 1d62af67d44179653f28bcd252646afe844da36d4674c52de3d00bc73a3ede9b03c16e2c820bef3eb2d5b9212689ae31474490603c4b7945b4b828b973be0943 SHA512 badd2cd94a6c51e7723932736ac8d66f251b5bd68d3c2f88c1aa803583bccc9d0bb1aa852d6529c353f89834f2bfb41623de2ea35ef0a1d96108452152c44c4d
+MISC metadata.xml 710 BLAKE2B 8ce6437cfec2d52048b7107c177bc025ea7770ac3aea2c86782f9b61ad6ba05b9c3df2f377ef97291356f97822721bda247047577383374252170f5835ee7f10 SHA512 f12b4505ad34c9171cb4547793c17406e4bee91f6b97efc39825d981d426fd729304ee72ac51471e8b4fea8cf6d194bc32990bec2206d661e510847729fc3819
diff --git a/dev-php/fedora-autoloader/fedora-autoloader-0.2.1.ebuild b/dev-php/fedora-autoloader/fedora-autoloader-0.2.1.ebuild
new file mode 100644
index 000000000000..bff9b57a001e
--- /dev/null
+++ b/dev-php/fedora-autoloader/fedora-autoloader-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fedora's Static PSR-4, PSR-0, and classmap autoloader"
+HOMEPAGE="https://github.com/php-fedora/autoloader"
+SRC_URI="https://github.com/php-fedora/autoloader/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+S="${WORKDIR}/autoloader-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Fedora/Autoloader"
+ doins -r src/.
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
diff --git a/dev-php/fedora-autoloader/fedora-autoloader-1.0.0.ebuild b/dev-php/fedora-autoloader/fedora-autoloader-1.0.0.ebuild
new file mode 100644
index 000000000000..0decde9fce07
--- /dev/null
+++ b/dev-php/fedora-autoloader/fedora-autoloader-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fedora's Static PSR-4, PSR-0, and classmap autoloader"
+HOMEPAGE="https://github.com/php-fedora/autoloader"
+SRC_URI="https://github.com/php-fedora/autoloader/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="test"
+
+RESTRICT="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+S="${WORKDIR}/autoloader-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Fedora/Autoloader"
+ doins -r src/.
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
diff --git a/dev-php/fedora-autoloader/metadata.xml b/dev-php/fedora-autoloader/metadata.xml
new file mode 100644
index 000000000000..551bb2bc4e84
--- /dev/null
+++ b/dev-php/fedora-autoloader/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Static PSR-4, PSR-0, and classmap autoloader.
+ Includes loader for required and optional dependencies.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">php-fedora/autoloader</remote-id>
+ </upstream>
+</pkgmetadata>