summaryrefslogtreecommitdiff
path: root/dev-php/doctrine/doctrine-2.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/doctrine/doctrine-2.6.4.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/doctrine/doctrine-2.6.4.ebuild')
-rw-r--r--dev-php/doctrine/doctrine-2.6.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/doctrine/doctrine-2.6.4.ebuild b/dev-php/doctrine/doctrine-2.6.4.ebuild
new file mode 100644
index 000000000000..10bd6546bbf1
--- /dev/null
+++ b/dev-php/doctrine/doctrine-2.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="orm-${PV}"
+DESCRIPTION="An object relational mapper for PHP"
+HOMEPAGE="https://www.doctrine-project.org/"
+SRC_URI="https://github.com/${PN}/orm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/php-7.1:*[cli,pdo]"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r lib/Doctrine
+ insinto /usr/share/php/Doctrine
+ exeinto /usr/share/php/Doctrine
+ doins bin/doctrine.php
+ doexe bin/doctrine
+ dosym ../share/php/Doctrine/doctrine /usr/bin/doctrine
+}