summaryrefslogtreecommitdiff
path: root/dev-php/cphplib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/cphplib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/cphplib')
-rw-r--r--dev-php/cphplib/Manifest4
-rw-r--r--dev-php/cphplib/cphplib-0.51-r1.ebuild29
-rw-r--r--dev-php/cphplib/files/constructor.patch42
-rw-r--r--dev-php/cphplib/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-php/cphplib/Manifest b/dev-php/cphplib/Manifest
new file mode 100644
index 000000000000..fe5c1a327f43
--- /dev/null
+++ b/dev-php/cphplib/Manifest
@@ -0,0 +1,4 @@
+AUX constructor.patch 877 BLAKE2B b2f1c1fbff365992961495729632075afaaa10e8383ebe04c8802ef6466a7b71565945adf8b3536e6bc58715a22ea1f6fad71d19d30afc33a4bbf06dde68a193 SHA512 0fb08f411829f0c041203cc14859c184036422af5aedb4829cfa1212153ff92e43c8e4889b3a7e1c943ebd1532e2aecab6e4b44147865726966ad804a2f0595d
+DIST cphplib-0.51.tar.bz2 117555 BLAKE2B e90371d11bb342bf63ef24616d03b1c1e5dc3d8d3eae8410cf2e44f84560cb6385afc9f2fb4690ec94244a6467aca6de71452093af8c61b98777561a15a10823 SHA512 b1db52bb241f4e996538fc6173a72a9ff8d6e19596808030ad1f7ed28b051d2e6f2ececf0cfcfd177a18cab049b5b1c4d3c8877cd93d4cb5705142d035d67818
+EBUILD cphplib-0.51-r1.ebuild 826 BLAKE2B 5c34e2e7c9a06f081244e56f666f99fb632564383018fa2d66cfedebe828d70c3bfaaf63e48eec78ec663c530b29aa7c6c42c8e681d6d9dd653dff44e7d789da SHA512 28ef36a3ff8dc6fffd76452f4286d4c36e56cfdeb6f3aa9cb423e82c4053ba52d233e153cad01dc69312c114c606c9965f91ac29bbb94110ecb8c1970c65f028
+MISC metadata.xml 316 BLAKE2B 5247b858ae90aa409456eed3ab250851ecc33f1514c7eb30cf810f1d1b2dd3bcb776b5a4e5e55d2884f4f36fe337da88798c0888c40ad5c37cc29531d27a7df7 SHA512 c07b2cc214a5a7f6f43c0ea18c7787ccc9caebc878bcf0e039c6155e00d6a444df3fa6429a1b6c808434398a342c5eed5473f26dbd6f7f165eeb4ff489c10b6e
diff --git a/dev-php/cphplib/cphplib-0.51-r1.ebuild b/dev-php/cphplib/cphplib-0.51-r1.ebuild
new file mode 100644
index 000000000000..c79a4a612094
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Cute PHP Library (cphplib)"
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cphplib/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-php/PEAR-DB-1.7.6-r1"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/constructor.patch" )
+
+src_install() {
+ local DOCS=( ChangeLog README TODO )
+ local -a HTML_DOCS
+ insinto "/usr/share/php/${PN}"
+ doins -r i18n cphplib_formular.inc cphplib.inc
+ use doc && HTML_DOCS=( doc/packages.html doc/blank.html
+ doc/classtrees_cphplib.html doc/index.html doc/cphplib/
+ doc/errors.html doc/__filesource/ doc/elementindex.html
+ doc/li_cphplib.html doc/elementindex_cphplib.html doc/media/ )
+ einstalldocs
+}
diff --git a/dev-php/cphplib/files/constructor.patch b/dev-php/cphplib/files/constructor.patch
new file mode 100644
index 000000000000..1ab88d212c1f
--- /dev/null
+++ b/dev-php/cphplib/files/constructor.patch
@@ -0,0 +1,42 @@
+diff -uarN a/cphplib_formular.inc b/cphplib_formular.inc
+--- a/cphplib_formular.inc 2006-05-25 05:03:44.000000000 -0400
++++ b/cphplib_formular.inc 2017-07-27 10:49:10.928727081 -0400
+@@ -130,6 +130,11 @@
+
+ function cphplib_formular($locale="de_DE")
+ {
++ __construct($locale);
++ }
++
++ function __construct($locale="de_DE")
++ {
+ parent::cphplib($locale);
+
+ $this->os_type = $this->os_type();
+@@ -1390,4 +1395,3 @@
+ }
+ }
+
+-?>
+\ No newline at end of file
+diff -uarN a/cphplib.inc b/cphplib.inc
+--- a/cphplib.inc 2006-05-25 05:03:58.000000000 -0400
++++ b/cphplib.inc 2017-07-27 10:59:51.910098156 -0400
+@@ -215,6 +215,11 @@
+ */
+ function cphplib($locale="de_DE")
+ {
++ __construct($locale);
++ }
++
++ function __construct($locale="de_DE")
++ {
+ if (!empty($locale))
+ {
+ $this->locale = $locale;
+@@ -4539,4 +4544,3 @@
+ }
+ }
+
+-?>
+\ No newline at end of file
diff --git a/dev-php/cphplib/metadata.xml b/dev-php/cphplib/metadata.xml
new file mode 100644
index 000000000000..ed619841de95
--- /dev/null
+++ b/dev-php/cphplib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cphplib</remote-id>
+ </upstream>
+</pkgmetadata>