summaryrefslogtreecommitdiff
path: root/dev-php/cli-prompt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/cli-prompt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/cli-prompt')
-rw-r--r--dev-php/cli-prompt/Manifest4
-rw-r--r--dev-php/cli-prompt/cli-prompt-1.0.0.ebuild22
-rw-r--r--dev-php/cli-prompt/files/autoload.php8
-rw-r--r--dev-php/cli-prompt/metadata.xml22
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-php/cli-prompt/Manifest b/dev-php/cli-prompt/Manifest
new file mode 100644
index 000000000000..1fbc70d6099a
--- /dev/null
+++ b/dev-php/cli-prompt/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 261 BLAKE2B 71987b4c16fe40a74fe8b84c22e855580ccd5901c1adef39d8a78ac2b48be6459e08dffadb979ec41f07d34ddfd88c8636e34a24f90941b4aedd0853b128b457 SHA512 e5eb2fe6feeacf29f0b2b6b5f8370ecb5e42d1d7f3464c0ba1f90565b6f0a15a6c3b79b6c8d1179f37c4fe8bee28c241b750af864b106c67dd7019c75aae38f9
+DIST cli-prompt-1.0.0.tar.gz 7538 BLAKE2B 650bb080c77471515d9baf31d1c5ea13fbfb4a9100e607e2f9c372c8c2ba0f6eac2d67ea0d2327bf30d1cbfaa65a8feb7e999b3a0b130f54e48c85ed8236cbe4 SHA512 5a1f6f999976f3b01d857890b5a06cfed377597397266b44d4aba324bedc2b9f73db5dc184ab40ee6632b43c80da99f5641366903bbc7bb7e18409cb367c8461
+EBUILD cli-prompt-1.0.0.ebuild 536 BLAKE2B c63bff6a789b815aeb911d8e7718cf056c79cd418d0be6a2330c81cb11a02ec59c3aca0f3898715e22c25e79b52f17096023cafd7f105df898421ae5362eac06 SHA512 de432496c42dfe1819c89d90b37404a2f236d83c8072969d36da16776ea3070a50023d333fda107cf454ccf9ceb878a5666bd7090e23f77cfaa0cb2b43ef2bd2
+MISC metadata.xml 708 BLAKE2B ff80a057a2ccf142b03191ef285e81ec250e145998eabed54849b6ad7cfe42f0b009b463268f6d792de97718310afdfab8c1f5c86e4853761958f1079284dcbe SHA512 87e434fed2ee3d6586a6e4cfdbc866a9aed25ad26c28ebca1cda29109031212430a97f0dc8d40668ef20fc355529f9141d03ab14ccc49e93a9ebf427294f6c78
diff --git a/dev-php/cli-prompt/cli-prompt-1.0.0.ebuild b/dev-php/cli-prompt/cli-prompt-1.0.0.ebuild
new file mode 100644
index 000000000000..4bf34feadb3c
--- /dev/null
+++ b/dev-php/cli-prompt/cli-prompt-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Allows you to prompt for user input on the command line"
+HOMEPAGE="https://github.com/Seldaek/cli-prompt"
+SRC_URI="https://github.com/Seldaek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Seld/CliPrompt"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
diff --git a/dev-php/cli-prompt/files/autoload.php b/dev-php/cli-prompt/files/autoload.php
new file mode 100644
index 000000000000..7a1acbd38c9f
--- /dev/null
+++ b/dev-php/cli-prompt/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for symfony-finder and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Seld\\CliPrompt\\', __DIR__);
diff --git a/dev-php/cli-prompt/metadata.xml b/dev-php/cli-prompt/metadata.xml
new file mode 100644
index 000000000000..4b3fb7237dc7
--- /dev/null
+++ b/dev-php/cli-prompt/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Allows you to prompt for user input on the command line,
+ and optionally hide the characters they type.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Seldaek/cli-prompt</remote-id>
+ </upstream>
+</pkgmetadata>