summaryrefslogtreecommitdiff
path: root/dev-php/ca-bundle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/ca-bundle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/ca-bundle')
-rw-r--r--dev-php/ca-bundle/Manifest4
-rw-r--r--dev-php/ca-bundle/ca-bundle-1.0.3.ebuild22
-rw-r--r--dev-php/ca-bundle/files/autoload.php8
-rw-r--r--dev-php/ca-bundle/metadata.xml24
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-php/ca-bundle/Manifest b/dev-php/ca-bundle/Manifest
new file mode 100644
index 000000000000..733ccd9e939d
--- /dev/null
+++ b/dev-php/ca-bundle/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 268 BLAKE2B 0b6618f45d1a4e03a317ea55b4af12c60c43f9eb98fe9b3cacc45e5cf505530cc4e332d5289365956abfb3eb882b3447d19919b5116d249d727b0c934f272eb3 SHA512 186ccfc3ae6669722d01948c266a9c0518e1da228095a880695b7de6502c9798203019622cc0c63e30fbf7abe94aa988b7c694bcc98522e04298aa90217b8ed8
+DIST ca-bundle-1.0.3.tar.gz 151659 BLAKE2B a8755af7041a1e093d06f6bf3bfdcd7461bd50ab5347f48285fb6e69d6e621c82c458c73625ed36d6745e91b0c7fabae37318da3674c47bb2813b78aa9483379 SHA512 e33629345d63121b7a6a46b0812afefad5adbc24fd5516eeb7471dd93b7e4126f144b6fc933b526796607fdc3fc9a99f5703188e15d905654d629591c555ad86
+EBUILD ca-bundle-1.0.3.ebuild 526 BLAKE2B d1f23cf223d8fafb9849c0884b8c1536db6e70a2600f91d25dc236fc5a79467fcd439933e71d7562855894ec2a6f60fcb3297e45c44df80d0dd78f10c8eadaa4 SHA512 0f2858fc082c4253f4b50f309a1f5f86538802302c8d97067210391d735f4a5274342ea234fe0a97d1f58f9fedd6d18bc996e2e08a5e43eab818295734e14315
+MISC metadata.xml 843 BLAKE2B d66b37ea7e1468303bbf544d3492a5f3108810a2a04bd5eec1562fa3b873e22cfc7922b46c96982900d8a0c7af7a22e4b33e9700057d32e238c35dd7fdaf5d06 SHA512 9cf3344f7122a81e5ce4b114a53af7c2cedc76e9607abffb906c70263b0c9dfab0209ee06be67ffc22d3da2e386fc376cc3aee007974e5338a259f853c5452fe
diff --git a/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild b/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild
new file mode 100644
index 000000000000..95b1abf40256
--- /dev/null
+++ b/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Find the system CA bundle or fall back to the Mozilla one"
+HOMEPAGE="https://github.com/composer/ca-bundle"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto /usr/share/php/Composer/CaBundle
+ doins src/CaBundle.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}
diff --git a/dev-php/ca-bundle/files/autoload.php b/dev-php/ca-bundle/files/autoload.php
new file mode 100644
index 000000000000..993360676f74
--- /dev/null
+++ b/dev-php/ca-bundle/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for composer/ca-bundle and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Composer\\CaBundle\\', __DIR__);
diff --git a/dev-php/ca-bundle/metadata.xml b/dev-php/ca-bundle/metadata.xml
new file mode 100644
index 000000000000..1fad9628ff21
--- /dev/null
+++ b/dev-php/ca-bundle/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Small utility library that lets you find a path to the system CA
+ bundle, and includes a fallback to the Mozilla CA bundle.
+ Originally written as part of dev-php/composer, now extracted and
+ made available as a stand-alone library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">composer/ca-bundle</remote-id>
+ </upstream>
+</pkgmetadata>