summaryrefslogtreecommitdiff
path: root/dev-php/ca-bundle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/ca-bundle
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/ca-bundle')
-rw-r--r--dev-php/ca-bundle/Manifest4
-rw-r--r--dev-php/ca-bundle/ca-bundle-1.0.3.ebuild22
-rw-r--r--dev-php/ca-bundle/files/autoload.php8
-rw-r--r--dev-php/ca-bundle/metadata.xml24
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-php/ca-bundle/Manifest b/dev-php/ca-bundle/Manifest
new file mode 100644
index 000000000000..792868847342
--- /dev/null
+++ b/dev-php/ca-bundle/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 268 SHA256 e4432f30b3120969792ca0af5544cbd68ca1d384a997f92f5d6424d9677a17c1 SHA512 186ccfc3ae6669722d01948c266a9c0518e1da228095a880695b7de6502c9798203019622cc0c63e30fbf7abe94aa988b7c694bcc98522e04298aa90217b8ed8 WHIRLPOOL 6632ff7476390853c5f4d93bbb58c82d6c7c8e0efdb81b93ae58dfe5e104a4e4fb248203a0ead62a23cb5e64d0723bb5ed11b3f88c874fb6e1e42423424a73e1
+DIST ca-bundle-1.0.3.tar.gz 151659 SHA256 29b33c5e75f15341cae2becb1715a76db129e6d37b5ff036a9eb366206b5bafd SHA512 e33629345d63121b7a6a46b0812afefad5adbc24fd5516eeb7471dd93b7e4126f144b6fc933b526796607fdc3fc9a99f5703188e15d905654d629591c555ad86 WHIRLPOOL 58f0bf54e59152ebf93998366822dd11521ea1caef46fd75d64badf6a4ee1bd1322de3431c7cba2ef4c06ec5865c2f6e065bc60e3743ddad8233b165778341c7
+EBUILD ca-bundle-1.0.3.ebuild 526 SHA256 5b39853f3743cf26a33cd254c12dc362206312fdc66cf2fe10c1f6b69aa07cfe SHA512 0f2858fc082c4253f4b50f309a1f5f86538802302c8d97067210391d735f4a5274342ea234fe0a97d1f58f9fedd6d18bc996e2e08a5e43eab818295734e14315 WHIRLPOOL a1f7b788926390fc4d08b54eadaae78481d29fbbd316a48ee1f26051645b68278c74b4bb01141fa617609d4ffaadc4b93099ba6145b993911e077b406b1ef03a
+MISC metadata.xml 831 SHA256 ea0e4a4c596404f93b080f4add694f52629f0cad2e50b18eb2b6c9879abf1aec SHA512 4b6dec85c4b3b632b941f821028359aa4f15fb8cace27cfb9a9d151db3ca27cb5bd88ad7a1e46c398b88db221a080ad28b9d1b13b5326b2f88fb424aff904338 WHIRLPOOL f6689630cc9673c9ac9f1d8b33534e64a3afff1d3de916af1cbfcea478e18eb93f7a4958d26ca19b44d81b81efce84cd4d59ceb2022ad3046888a31e77d47d49
diff --git a/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild b/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild
new file mode 100644
index 000000000000..95b1abf40256
--- /dev/null
+++ b/dev-php/ca-bundle/ca-bundle-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Find the system CA bundle or fall back to the Mozilla one"
+HOMEPAGE="https://github.com/composer/ca-bundle"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto /usr/share/php/Composer/CaBundle
+ doins src/CaBundle.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}
diff --git a/dev-php/ca-bundle/files/autoload.php b/dev-php/ca-bundle/files/autoload.php
new file mode 100644
index 000000000000..993360676f74
--- /dev/null
+++ b/dev-php/ca-bundle/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for composer/ca-bundle and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Composer\\CaBundle\\', __DIR__);
diff --git a/dev-php/ca-bundle/metadata.xml b/dev-php/ca-bundle/metadata.xml
new file mode 100644
index 000000000000..f75495b02355
--- /dev/null
+++ b/dev-php/ca-bundle/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Small utility library that lets you find a path to the system CA bundle,
+ and includes a fallback to the Mozilla CA bundle.
+ Originally written as part of dev-php/composer,
+ now extracted and made available as a stand-alone library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">composer/ca-bundle</remote-id>
+ </upstream>
+</pkgmetadata>