summaryrefslogtreecommitdiff
path: root/dev-php/PHP_Timer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PHP_Timer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PHP_Timer')
-rw-r--r--dev-php/PHP_Timer/Manifest7
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild18
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild31
-rw-r--r--dev-php/PHP_Timer/files/autoload.php13
-rw-r--r--dev-php/PHP_Timer/files/channel.xml16
-rw-r--r--dev-php/PHP_Timer/metadata.xml11
6 files changed, 96 insertions, 0 deletions
diff --git a/dev-php/PHP_Timer/Manifest b/dev-php/PHP_Timer/Manifest
new file mode 100644
index 000000000000..57944c6ab16d
--- /dev/null
+++ b/dev-php/PHP_Timer/Manifest
@@ -0,0 +1,7 @@
+AUX autoload.php 281 BLAKE2B e1265714ef958a2490b2c039a0def4cd3e2a26ff035d4c689e10f0eb9c9f26878fb537fcf42ede6d26fed2ee36dd73e258fa116d7cc6cd57c80eb990e54cdc33 SHA512 e9e0e6d3bd52d7a524472d4d65aa21e0f1a767fbfc284e9d628eea1414e87ba5e692d3968005d3afcbd86a598538c2edf241a09d5d66cf9cfbb57efdc758db21
+AUX channel.xml 804 BLAKE2B d6a965a41a220f07e3a0d206bc3359e2649b55d186e7975726c1b0ad344e063ca1fa98cde446078346384e946f6b31f9caaf49cf7c82b4568f697a1ba0d2e633 SHA512 44f5d66b967cff45b87795609e6dd14443a4ce5ae8f3430a281429ba21e834bc3feb7f539fb6cd8349017eb301054a33dfcd7062d58f9fd0c1c7cd1892580092
+DIST PHP_Timer-1.0.5.tgz 3597 BLAKE2B cf82c3ff61a1f96a94a5d3743270be3262bc2ea28d7d71cd1c93a07c7bec950597c4da5d6dd23e4b58b8aad7c2e3bdb7aea07d761ef096e898088ca2296b43cf SHA512 da030dec608d1f8d447da6ce40e995ca818064e3a4b2f2eca1819a77a12875843a25bba1ffd253043ef3ac62a6dc1a16c5e7ba9b792b99b54d0713090478be84
+DIST PHP_Timer-1.0.9.tar.gz 3740 BLAKE2B d551fd676046e6bb653fb9a9bde7a976b9b2081d26caee23177b899fa01e11ae1fb2183234ab43745798c058222574b1523064cc07d25485315eef9090f892a5 SHA512 96db90cf2af18fabcf44bdd4dbb5d298402ed2c8e49f3033fd1b89b3aa8c880d9f8677897d4d542a0db6348bdd9c697042deb0b6e26242adebfde1bcdb4bc559
+EBUILD PHP_Timer-1.0.5.ebuild 427 BLAKE2B 7f8cd242ba49525527a20fad8dc4997e4dd451d4049962de71978afc5350e2beee40de331f414930bb2f50c8beed03727ec3e840cc13d5324f01b69efb5b6ba5 SHA512 802255716d8340c81bb2c0073064c511eaa4591f8061155cddd30cd53084100e55e71572b7378d7680dcb23cc4811d36cf527d6850ca9a4b6d1ce48ee1820525
+EBUILD PHP_Timer-1.0.9.ebuild 750 BLAKE2B 12f27ed935861e1dcb68ff4d2cf139854195fd596663933228badeac76923c7f05a9cb17aae394a97a49ce761f85923f781d1564d63a8aea2e23e6e60bb8cb25 SHA512 cb6d6dbd8106f2bbb666eab295807ae1873bcdf502c81f7c0e1dad1e35eb88235c3de4b2c4ef869bebb2f82d5e955c55b824a16d515a6a779f4018c4e3d0a32d
+MISC metadata.xml 331 BLAKE2B a4a67930fc96c32bc75804af627a97742700619e362bf59992ee8a8882b2cffcd4fa6de297abbcc42d6e33119fd10933e65a1291484acf4dd091c5ed55dcd81f SHA512 e3e0aaa2728b2f5f65592f56027ae9674e7e9abf4bdb2fef90854b6d8d270f4f6a103c4588401ef076d53fd3c4c2fceb2d9b5145dc3af43c8913ccd5f0e2ee53
diff --git a/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild b/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild
new file mode 100644
index 000000000000..e0d5a2764c10
--- /dev/null
+++ b/dev-php/PHP_Timer/PHP_Timer-1.0.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_DOMAIN="pear.phpunit.de"
+PHP_PEAR_PKG_NAME="PHP_Timer"
+
+inherit php-pear-r2
+
+DESCRIPTION="Utility class for timing"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+HOMEPAGE="http://pear.phpunit.de/"
+SRC_URI="http://${PHP_PEAR_URI}/get/${PEAR_P}.tgz"
diff --git a/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild b/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild
new file mode 100644
index 000000000000..5c6c9dfe8195
--- /dev/null
+++ b/dev-php/PHP_Timer/PHP_Timer-1.0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="php-timer"
+
+DESCRIPTION="Utility class for timing"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/PHP/Timer
+ doins -r src/Timer.php
+ doins "${FILESDIR}/autoload.php"
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}
diff --git a/dev-php/PHP_Timer/files/autoload.php b/dev-php/PHP_Timer/files/autoload.php
new file mode 100644
index 000000000000..bb0974e087d6
--- /dev/null
+++ b/dev-php/PHP_Timer/files/autoload.php
@@ -0,0 +1,13 @@
+<?php
+/* Autoloader for dev-php/PHP_Timer */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ array(
+ 'php_timer' => '/Timer.php',
+ ),
+ __DIR__
+);
diff --git a/dev-php/PHP_Timer/files/channel.xml b/dev-php/PHP_Timer/files/channel.xml
new file mode 100644
index 000000000000..91bb6786f543
--- /dev/null
+++ b/dev-php/PHP_Timer/files/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.phpunit.de</name>
+ <summary>PHPUnit PEAR Channel</summary>
+ <suggestedalias>phpunit</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.phpunit.de/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/dev-php/PHP_Timer/metadata.xml b/dev-php/PHP_Timer/metadata.xml
new file mode 100644
index 000000000000..2774b13055f6
--- /dev/null
+++ b/dev-php/PHP_Timer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/php-timer</remote-id>
+ </upstream>
+</pkgmetadata>