summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-php/PHPMailer
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/Manifest2
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.0.5.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 2596bd565cd5..94152aa689f6 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,3 +1,5 @@
DIST PHPMailer-5.2.26.tar.gz 159174 BLAKE2B 989ee85f6ca374bd7f4accf3d18fbd173bbbd3176e6846c9a2aec68f3bfca4ead4e0197f6287e2bc8ed4a125bf7fcb53240a1f8ce6a1813eaffb66067c2c4e9e SHA512 4c3e324ecd1dd23eb40f14ee785fb9b353b742ff4fb26fe0586622038157e60d64560f5ba4a625f16fad6568954d685ebbe436d88bc427d5bd260c056815b656
+DIST PHPMailer-6.0.5.tar.gz 88092 BLAKE2B 0b2113b54d547d788c54cbcf18fe134a6b08f6b9eabcbad308a7d0bba8e95426fd8be77419419cbe0379be080350a1caf1690cbe3f096c178cc3a8c9506d9529 SHA512 5b18700ef26fe5de20a7ca291ece44b897182c603ed8187e0f711099325b35b20f8dbab2c456eaac1338731356661237d9b249c2f40051807b0d58ead612013c
EBUILD PHPMailer-5.2.26-r2.ebuild 1960 BLAKE2B 7bb0a7ea8e71c6bff9cc37972f0e62b5e71184707da7f7543d8fa5578ecb090ce8be4086ad2abb55675ec3647435e2559cd0acc84e4fd0cc5bbb12e1fd290668 SHA512 2c147dd3d6c8ecefd05716a8767fb45e373af2845adf7a2d18bc894374f78fedeff614addd829f0137d9dc6bfd40059548068cac8af82e9c25b1cec839fea746
+EBUILD PHPMailer-6.0.5.ebuild 2216 BLAKE2B 9c5283ddeffb1ab3fd93782251d78bc593d0905e623e5c7babd34e2b82f44ecbec61d5d3f7faae4822fad8e891940f3c6792498434cca5ec6a443f63cb87e76f SHA512 d3b4191b3facd821c13527fb7c8b73f89368e87ce7bb41c8e102e66414cbaa3b897b1603b8e3cbb2b22d6d7193ce5c16a8b24765062a8fdf332b5edf72dc08a1
MISC metadata.xml 446 BLAKE2B 178ea98081e664641c7a8632a1c7dac9b5cac8992b0b945208f5ef654633340daced2473bbdc342b70d8b168ac2206ba132f7ab9601f61b5436f3eb3e0441ca1 SHA512 3dfce858cb0e00b526f04a5764a6173d4711db4f21f52b6d827b82f1cddea4e33f533e645dae95d0bb6a69699b00520a414f2e322c76b56aee1e4ea047bb4bb5
diff --git a/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild b/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild
new file mode 100644
index 000000000000..99907db766fb
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.0.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+ eapply_user
+}
+
+src_compile(){
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install(){
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}