summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PHPMailer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/Manifest3
-rw-r--r--dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild64
-rw-r--r--dev-php/PHPMailer/metadata.xml15
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
new file mode 100644
index 000000000000..2596bd565cd5
--- /dev/null
+++ b/dev-php/PHPMailer/Manifest
@@ -0,0 +1,3 @@
+DIST PHPMailer-5.2.26.tar.gz 159174 BLAKE2B 989ee85f6ca374bd7f4accf3d18fbd173bbbd3176e6846c9a2aec68f3bfca4ead4e0197f6287e2bc8ed4a125bf7fcb53240a1f8ce6a1813eaffb66067c2c4e9e SHA512 4c3e324ecd1dd23eb40f14ee785fb9b353b742ff4fb26fe0586622038157e60d64560f5ba4a625f16fad6568954d685ebbe436d88bc427d5bd260c056815b656
+EBUILD PHPMailer-5.2.26-r2.ebuild 1960 BLAKE2B 7bb0a7ea8e71c6bff9cc37972f0e62b5e71184707da7f7543d8fa5578ecb090ce8be4086ad2abb55675ec3647435e2559cd0acc84e4fd0cc5bbb12e1fd290668 SHA512 2c147dd3d6c8ecefd05716a8767fb45e373af2845adf7a2d18bc894374f78fedeff614addd829f0137d9dc6bfd40059548068cac8af82e9c25b1cec839fea746
+MISC metadata.xml 446 BLAKE2B 178ea98081e664641c7a8632a1c7dac9b5cac8992b0b945208f5ef654633340daced2473bbdc342b70d8b168ac2206ba132f7ab9601f61b5436f3eb3e0441ca1 SHA512 3dfce858cb0e00b526f04a5764a6173d4711db4f21f52b6d827b82f1cddea4e33f533e645dae95d0bb6a69699b00520a414f2e322c76b56aee1e4ea047bb4bb5
diff --git a/dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild b/dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild
new file mode 100644
index 000000000000..1cd077177b3f
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-5.2.26-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+DEPEND="${RDEPEND}
+ doc? ( dev-php/phpDocumentor )"
+
+src_compile(){
+ if use doc; then
+ phpdoc --filename="class.*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install(){
+ # To help out the Composer kids, most of the documentation and
+ # tests are missing from the release tarballs.
+ insinto "/usr/share/php/${PN}"
+ doins -r *.php language extras
+
+ use examples && dodoc -r examples
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/${PN}Autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}
diff --git a/dev-php/PHPMailer/metadata.xml b/dev-php/PHPMailer/metadata.xml
new file mode 100644
index 000000000000..a670ac4443f8
--- /dev/null
+++ b/dev-php/PHPMailer/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PHPMailer/PHPMailer</remote-id>
+ </upstream>
+</pkgmetadata>