summaryrefslogtreecommitdiff
path: root/dev-php/PHPMailer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-php/PHPMailer
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-php/PHPMailer')
-rw-r--r--dev-php/PHPMailer/Manifest2
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.1.7.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 5f16be4d64dd..a9d34951dee4 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,5 +1,7 @@
DIST PHPMailer-5.2.28.tar.gz 159284 BLAKE2B 866a38c60ac55cbd8aefec5ad82211575e672578ddff1af435e676c7058b0a090884f3e5f2c1e6f30c94b01e393f982f644e578ea22c931ffb8a93be717e379b SHA512 c2dd762b8958d1dc68fec52d7daae7337e05cadcbcf9e67c27247c808877cf3132e80cf6d4c9c577f8ad9203e433282e45f2166bccce025bcc4477724eb7036f
DIST PHPMailer-6.1.6.tar.gz 94769 BLAKE2B 6689f4429c0847de41016325553d58d544f78d5f8a94d9014841435a3cf161e4e10b14fe2cbb61c737bf75d87f2dc4cde66885c06a0b6992a472f0f46fe5dd6b SHA512 25530e6c5513e89729a5b253565143a5a9a35ee5f7813637eee18ca1d604cb83625f7beb106e56536f681d7ec4332fcd3cddcac5da7c73f730db1b056ba5b2e4
+DIST PHPMailer-6.1.7.tar.gz 95102 BLAKE2B 8a1a09aa8f1c82900d881cf82e4a44705afbabc2f38b7bcf8b069a23c426f690dfbebd30c27a30dfbd8a3ad10e75e88fab4fa064bd44308b837455b84a41cad9 SHA512 4b37e11bb99966b8151b64a469125f249091c9b57ef729549735f37869fbaf1a1fb1a3f9d19822c824e909e8b53b696d3cb0d5180683e94968145a968622c2e8
EBUILD PHPMailer-5.2.28.ebuild 1962 BLAKE2B e5386bf9d75ae81df44fa8703e2183ff79b39054c14bf49a1b57774d148aa5d460c7f5310a98d447a114187844c0453e4017eb5cfb1f679e4910ad60b83cd6d7 SHA512 b6eab2bf9413f7af3083f92a0d8f3252a3773526711c724786df3b3c056472f6a0d7a0725ae58adc3860cff8c5ee9707a7198e0193a7fedf31c878408d385b85
EBUILD PHPMailer-6.1.6.ebuild 2219 BLAKE2B 08a599591d6bee673c5df6b47d9c9aea0db8e7ba8d46d7568afbb3d72ee65d0e23215d5f77ac3ac04e70ca26a98847323b9a54dd4adef8f453efc90e89d52a3f SHA512 c69da2436be943fb96828db9268f73d34ac129b21521800f510ef79db257b090627f8bc5c384708f38bc9aec024116461b1a9bfce2dc9b0b7e20c23fc41dad27
+EBUILD PHPMailer-6.1.7.ebuild 2219 BLAKE2B 08a599591d6bee673c5df6b47d9c9aea0db8e7ba8d46d7568afbb3d72ee65d0e23215d5f77ac3ac04e70ca26a98847323b9a54dd4adef8f453efc90e89d52a3f SHA512 c69da2436be943fb96828db9268f73d34ac129b21521800f510ef79db257b090627f8bc5c384708f38bc9aec024116461b1a9bfce2dc9b0b7e20c23fc41dad27
MISC metadata.xml 446 BLAKE2B 178ea98081e664641c7a8632a1c7dac9b5cac8992b0b945208f5ef654633340daced2473bbdc342b70d8b168ac2206ba132f7ab9601f61b5436f3eb3e0441ca1 SHA512 3dfce858cb0e00b526f04a5764a6173d4711db4f21f52b6d827b82f1cddea4e33f533e645dae95d0bb6a69699b00520a414f2e322c76b56aee1e4ea047bb4bb5
diff --git a/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild b/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild
new file mode 100644
index 000000000000..e27c5fd93328
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.1.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+ eapply_user
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}