summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-XML_RSS
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-XML_RSS
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-XML_RSS')
-rw-r--r--dev-php/PEAR-XML_RSS/Manifest5
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild17
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild30
-rw-r--r--dev-php/PEAR-XML_RSS/metadata.xml12
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/Manifest b/dev-php/PEAR-XML_RSS/Manifest
new file mode 100644
index 000000000000..d928017d61df
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/Manifest
@@ -0,0 +1,5 @@
+DIST XML_RSS-1.1.0.tgz 8178 BLAKE2B da290ea2e656372478435451b5043f3254e1a06423495c62c753b636208ece31e5b9aebe59a9b84254aac70d2088b4c35f78b763b6045d29c467ff0989bbc6fa SHA512 947b040ec71728328bad0130da874132c12e8c14a37f57b0ebc4e9db26aed49d0f9702e20ae401bd92782e1895de71dbd5daf09adebec0eaf268c77dfe183c24
+DIST XML_RSS-1.1.0a1.tgz 6717 BLAKE2B f38aaa6981d94668031272cd48f5648ce9fec499fde4627b6291d1a9c0dea4db72779e3ce7a089be9ee5d23ad56d05c6bd3ffce031b9ef3f4fac5360c3da4420 SHA512 e88c7618cad60a775c07ac26aedf05b7ce7ab3c9f012f3e638031b3567227db237ee2e1238fa051f9f415388a5d7c131af02b8200e08c01a9078654ea5877ce8
+EBUILD PEAR-XML_RSS-1.1.0.ebuild 494 BLAKE2B 81e459768c0ab8d048f6765c65ce5427e9f32aa5a9a9a55df0f6b46796b68e194d7d2bbf20d81f2ef5ac746e3cdd311968b62fe7796a9f6c7648fe4e938848b0 SHA512 5c3d036faf76e1c9efe9bb61c0b8604f953d4b9db00d2cd169694fd26b7ef87a847abcf547c91db7939b494883216c29ca8beb2b8ff54cda771311fb7cecb9d3
+EBUILD PEAR-XML_RSS-1.1.0_alpha1.ebuild 748 BLAKE2B 13bb6be198b8b2e231073fd84b25124be63ac6388caa591f0adc603bdf88b514089abacb360a1731e1eea5657787a704a9ab563eba4c5367533a0226c23fde23 SHA512 1981adb9871b97c0e4a5da8938ab217504e6298c64e03b25aea6ddd3f01007b919528b5b3f854a1815d71d3077a8da986db97a52786d852bd8728d89d0f0a427
+MISC metadata.xml 373 BLAKE2B 23ac6ae6766ff928da3558d2c05d6ff025f56b76045044634d1706b046bfd1fe741dafc1ed10489113521f23e2ccd95f8d529d8be240948ee90f09ba236d9dae SHA512 e5be199ccfe81e85816b693f8b624ad2346e8948717dd26496e8e9f4b048c9189515fb11cabbe55a26f81e448937db5f1f16f37cb59bf3d24c3e3a68725e4e30
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild
new file mode 100644
index 000000000000..bd575d2b9911
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# Only needs PEAR_Exception (not in the tree), not all of PEAR.
+# This can be made into an || dependency if we add PEAR_Exception.
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
+ dev-php/PEAR-XML_Parser"
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
new file mode 100644
index 000000000000..ee29e7f4a89e
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/alpha/a}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+# Only needs PEAR_Exception (not in the tree), not all of PEAR.
+# This can be made into an || dependency if we add PEAR_Exception.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-XML_Parser"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r XML
+}
diff --git a/dev-php/PEAR-XML_RSS/metadata.xml b/dev-php/PEAR-XML_RSS/metadata.xml
new file mode 100644
index 000000000000..5df328cb979e
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/XML_RSS</remote-id>
+ <remote-id type="pear">XML_RSS</remote-id>
+ </upstream>
+</pkgmetadata>