summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild')
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..0511a5abb0a6
--- /dev/null
+++ b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP parser for RDF and RSS documents"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-XML_Parser-1.3.8-r1"
+BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+PATCHES=( "${FILESDIR}/XML_RSS-1.1.0-php8.patch" )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/_Framework_/\\Framework\\/' \
+ -e 's/_TextUI_/\\TextUI\\/' \
+ tests/*.php
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/XML/RSS.php" \
+ --cache-result-file="${T}/test-results.cache" tests || die
+}