summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild')
-rw-r--r--dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
new file mode 100644
index 000000000000..e228a7700964
--- /dev/null
+++ b/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5.2_p20180314.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
+SRC_URI="https://github.com/pear/VersionControl_SVN/archive/6c9580df92f0cc77a6eb6fcc216c56913bf308e7.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RDEPEND=""
+DEPEND="test? ( dev-vcs/subversion dev-php/phpunit )"
+S="${WORKDIR}/PEAR-${PHP_PEAR_PKG_NAME}-${PV}"
+
+src_prepare() {
+ einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
+ sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
+ sed -i 's/ +%d / %i /' tests/resetxml_19910.phpt || die
+ default
+}
+
+src_test() {
+ phpunit tests || die "Tests failed"
+}