summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Var_Dump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Var_Dump
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Var_Dump')
-rw-r--r--dev-php/PEAR-Var_Dump/Manifest5
-rw-r--r--dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild33
-rw-r--r--dev-php/PEAR-Var_Dump/metadata.xml11
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/PEAR-Var_Dump/Manifest b/dev-php/PEAR-Var_Dump/Manifest
new file mode 100644
index 000000000000..1118ec7f13f6
--- /dev/null
+++ b/dev-php/PEAR-Var_Dump/Manifest
@@ -0,0 +1,5 @@
+DIST Var_Dump-1.0.4.tgz 17426 SHA256 11eacb911020cbcc953f8048311c5f15bdc0cba959315ea84ae8243a3282198a SHA512 1d31fcc3519feeee2ec94fc6d8b919672cf4a1be80d6b63c0a52b30792b9c936a7b984033a4357a64cd937193a55daf67fb649444f8303f1332f7d7c793b2e89 WHIRLPOOL b998edb11ab5fefe4828c854dddfbdf344876a3eae1fafe32efab6386b8f8238990705edf81f1dae3d836f2066cd1981120f38a46d851620cef0ea509eca5c69
+EBUILD PEAR-Var_Dump-1.0.4-r3.ebuild 907 SHA256 21a58a5d95aff662fd9d123b9f48e059f783131c0045539c011b5117dec57e39 SHA512 6b2dc80cf203c6f594397183c2d68aaa29a98de8b5f0d47dd74b6e92ab03356f80456c559d96d7d941e1a736f9d84bb49d5404e7c47fe1a333903df9619c48e6 WHIRLPOOL c939f04206055f70ac7184e4184f3b618726146b8ebcb501fef35ba98fe4af38ca36391fc588871e5be2412d1805f6214233c57a59d6341a2125eb30285167b9
+MISC ChangeLog 2450 SHA256 b87037781bb7ed3611f4f6fd3a728f7daabf06670a80310ea5cb9ebf2054550c SHA512 be84b524ab7914803e7dc09a98f286fae667dbeff498eb2003dbfea5f016ae452a956d5153d7d62426bbaeaa5b005a03a17094da0174bd50f81915fc8999b9e4 WHIRLPOOL 6757999d3079e7e4f5d23d07a2ce15271d53b32b981ddd8a9337e85338f28ed29cc1d1695abace92a95a8e078270ebbe912e7a2423031fe931e59d3d5296280b
+MISC ChangeLog-2015 1090 SHA256 251150529aa8c79add4093f04d5d0d172ae375ba06c5d0ca2186cdb60a554cee SHA512 498721a96efb25e179fcf521a7add9dd4978f6ef6ee5a3266f7a1f33f1037ea730b7c964c52750fc8056216f9b766b8f2145354f9782c3b69c91490997ab372b WHIRLPOOL acf0fbdfd7954cac0a7c6c5e61f99f84ea7a52918cce5922803779d49cf0ba94e73422ee2d100db1894171c7e7fe3e1895b08e87452b80b9b72601ee96606b3f
+MISC metadata.xml 310 SHA256 d7eb3aebe6353b15698809c3d1ded1948159aa16cb01e34f5ba9bbd5805d7e2f SHA512 6fbd4f6ac4419473c097c4f09f448e0a2d81a7bb3d8d93fa79fa4ef0b2cff7ca463cd985b60bc5e7572230eb9296e37c446adb781c5d68e95510b999ec1dc66c WHIRLPOOL 672b05603d8c5eacd3562bf192855156aa199156cf6a73e6bbe3fb7172f893d684e5ed14e103a0da7c4ea578bcf9c5d3ec8a54fa9cb5f3959907a554f3be5803
diff --git a/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..707cff167f52
--- /dev/null
+++ b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Dump structured information about a variable"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+# The test suite fails due to some deprecation warnings that are output.
+# The test cases themselves set error_reporting(E_ALL), so there's no
+# easy way to override it.
+RESTRICT=test
+
+src_install() {
+ use examples && dodoc -r docs/example*.php
+ php-pear-r2_src_install
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Var_Dump/metadata.xml b/dev-php/PEAR-Var_Dump/metadata.xml
new file mode 100644
index 000000000000..08b46f8f0cb9
--- /dev/null
+++ b/dev-php/PEAR-Var_Dump/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Var_Dump</remote-id>
+ </upstream>
+</pkgmetadata>