summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Validate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Validate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Validate')
-rw-r--r--dev-php/PEAR-Validate/Manifest4
-rw-r--r--dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild22
-rw-r--r--dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch19
-rw-r--r--dev-php/PEAR-Validate/metadata.xml8
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-php/PEAR-Validate/Manifest b/dev-php/PEAR-Validate/Manifest
new file mode 100644
index 000000000000..896db2de72cf
--- /dev/null
+++ b/dev-php/PEAR-Validate/Manifest
@@ -0,0 +1,4 @@
+AUX 0.8.5-fix-test-php7.patch 905 BLAKE2B 5d000b990cd38d697af861ff828f2e9efd8fdef0e2a6fec87fbc60208c1a9f40686c5c0be63cdf862221311f235f87bccb975cf78bb4d5f2b03be6916d3899bb SHA512 44aa6cb09f19ad3246bc7e6d825de786139da433564b902bfff020be52b14f554f752f0ca7f790d378a74a3a62e15cf13383a9bff25db2f67e4496d5bcef5e7b
+DIST Validate-0.8.5.tgz 21668 BLAKE2B 5f1897f9a796bab047beb7bdcf79726f58f069874cb1d08a17078c8d974bed626b3e37dd792e8b941fd0115d9060986278d459037580adedf6088ef51d5f2c13 SHA512 4e2e330b0a74a24d18af262ef42d872ab9eb2386e11c5647d898c60e11a29d06c97c0295cdf0999c3a4805f3f1efae2949c54520da50cf6adfcc5a6c4f6e1b63
+EBUILD PEAR-Validate-0.8.5-r1.ebuild 541 BLAKE2B 9ca8ea0fd971fa165ac0e8cf9f5e83a5f7a30aecaa477c31f1aae3fb5cc02615d470ff2adc89d745f5aa9e3ba6f3e08eb7a66dd0509ac6ba8931adbaa9e056f2 SHA512 46c9b99ec0de1cfc902c9bc36a90125825c95437f4d78ed79ed71dde19a9a168c67ed4e47bda7e21ac4f2fe3a3a792f9287e38a114bdec8a92b0ecfbc23d4af2
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild b/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..61561fcf8e93
--- /dev/null
+++ b/dev-php/PEAR-Validate/PEAR-Validate-0.8.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+
+DESCRIPTION="Validation class"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR dev-php/PEAR-Date )"
+RDEPEND="!minimal? ( dev-php/PEAR-Date )"
+PATCHES=( "${FILESDIR}/0.8.5-fix-test-php7.patch" )
+HTML_DOCS=( docs/Example_Locale.php docs/sample_multiple.php )
+
+src_test() {
+ peardev run-tests tests || die
+}
diff --git a/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch b/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch
new file mode 100644
index 000000000000..069c5467d049
--- /dev/null
+++ b/dev-php/PEAR-Validate/files/0.8.5-fix-test-php7.patch
@@ -0,0 +1,19 @@
+From a22b5cf2c7e4b4cf366c311150721961d9b456ea Mon Sep 17 00:00:00 2001
+From: Christian Weiske <cweiske@cweiske.de>
+Date: Thu, 16 Jul 2015 00:38:55 +0200
+Subject: [PATCH] Make tests run on PHP 7
+
+diff --git a/Validate.php b/Validate.php
+index a8f621c..ea6cfa7 100644
+--- a/Validate.php
++++ b/Validate.php
+@@ -583,7 +583,8 @@ function email($email, $options = null)
+ if ($use_rfc822? Validate::__emailRFC822($email, $options) :
+ preg_match($regex, $email)) {
+ if ($check_domain && function_exists('checkdnsrr')) {
+- $domain = preg_replace('/[^-a-z.0-9]/i', '', array_pop(explode('@', $email)));
++ $parts = explode('@', $email);
++ $domain = preg_replace('/[^-a-z.0-9]/i', '', array_pop($parts));
+ if (checkdnsrr($domain, 'MX') || checkdnsrr($domain, 'A')) {
+ return true;
+ }
diff --git a/dev-php/PEAR-Validate/metadata.xml b/dev-php/PEAR-Validate/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/PEAR-Validate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>