summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_Wiki_Mediawiki
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Text_Wiki_Mediawiki
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Text_Wiki_Mediawiki')
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/Manifest4
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild26
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch36
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest b/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
new file mode 100644
index 000000000000..8117060a6f95
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
@@ -0,0 +1,4 @@
+AUX 0.2.0-constructor.patch 1554 BLAKE2B 0c8686ac4e11faecc21ef17524e005b580aa887694653318558676f513bddaa3fc33b3efd6763f458ec10fa52559045c8c2d9a9362b2bf66a61d03e5cf855bdb SHA512 7202a7e15bda9dce52dc52c6807abf7f0fb1c5957d2c74c9442c92286aeaf044e2eab1cd062df66345a109a5f574e136bfc2b0d309bdc78f3d099a08b2d667f8
+DIST Text_Wiki_Mediawiki-0.2.0_p20140604.tar.gz 22941 BLAKE2B d208b4df7e01a2b28e44ada0226be0f183fe6ffefe742f9b6cb4f2b366f915ae46d950d574a8357cbec273f41792f17a639f5512613628ee60ed137d909be9dd SHA512 aef4d18a4a0b9f41dc4bad701a90a2e7d674851b63206db9dd87cf87d6705991c8221e41cdbb8d2572a950520ce87db96105a009e4189e48b8e7f5df0f460ee5
+EBUILD PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild 762 BLAKE2B f354a9a3bbd91418c06b70c16e8b0a86811a76cfdf7a59ceaf1fac48132da497ad3a71b00e82234ba9bc74dc3fa50faa419f2ec050a5fa23db5baf62a2a6f880 SHA512 521bd3cc516ed6ddd3c7163479504900c51e4ce4cf548bfb64fc84abb1dc1984bb067d425b6946c86cdfe19d897d481f694c8333120e273e5e670d9a57433050
+MISC metadata.xml 235 BLAKE2B 5b10304feea18aae1822be7d29bcce06c8715193b14a3dd2c4d79eb75e2767670352e2ca11e06b9a10ec04b63020a18254cd167e6d6be9072f4a200ca5d11ec4 SHA512 0b3e95bbf68eddf74289dad50f8828cffce2d904ff6f9bd5468177de979677cac11da84d1e0302c52b72085915b9d1b3496107172e5726520d51dad1981daf64
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild b/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
new file mode 100644
index 000000000000..ad7c16118923
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+SRC_URI="https://github.com/pear/Text_Wiki_Mediawiki/archive/11a902741d3f8cc6010fb97b825d66345143e4dc.tar.gz -> ${PEAR_P}.tar.gz"
+DESCRIPTION="Mediawiki parser for Text_Wiki"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RDEPEND=">=dev-php/PEAR-Text_Wiki-1.2.2_p20170904"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+PATCHES=( "${FILESDIR}/0.2.0-constructor.patch" )
+
+src_test() {
+ phpunit tests/Text_Wiki_Parse_Mediawiki_Test.php || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/.packagexml
+ newins package.xml "${PEAR_P}.xml"
+}
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch b/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
new file mode 100644
index 000000000000..edd8e3572de0
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
@@ -0,0 +1,36 @@
+diff -aurN a/Text/Wiki/Mediawiki.php b/Text/Wiki/Mediawiki.php
+--- a/Text/Wiki/Mediawiki.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Mediawiki.php 2018-02-14 13:36:18.777893414 -0500
+@@ -87,7 +87,7 @@
+ * @param array $rules The set of rules to load for this object.
+ */
+ function __construct($rules = null) {
+- parent::Text_Wiki($rules);
++ parent::__construct($rules);
+ $this->addPath('parse', $this->fixPath(dirname(__FILE__)).'Parse/Mediawiki');
+ }
+ }
+diff -aurN a/Text/Wiki/Parse/Mediawiki/Url.php b/Text/Wiki/Parse/Mediawiki/Url.php
+--- a/Text/Wiki/Parse/Mediawiki/Url.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Parse/Mediawiki/Url.php 2018-02-14 13:40:21.974024459 -0500
+@@ -87,7 +87,7 @@
+ */
+ function __construct(&$obj)
+ {
+- parent::Text_Wiki_Parse($obj);
++ parent::__construct($obj);
+
+ // convert the list of recognized schemes to a regex-safe string,
+ // where the pattern delim is a slash
+diff -aurN a/Text/Wiki/Parse/Mediawiki/Wikilink.php b/Text/Wiki/Parse/Mediawiki/Wikilink.php
+--- a/Text/Wiki/Parse/Mediawiki/Wikilink.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Parse/Mediawiki/Wikilink.php 2018-02-14 13:40:46.030542359 -0500
+@@ -99,7 +99,7 @@
+ function __construct(&$obj)
+ {
+ $default = $this->conf;
+- parent::Text_Wiki_Parse($obj);
++ parent::__construct($obj);
+
+ // override config options for image if specified
+ if (in_array('Image', $this->wiki->disable)) {
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml b/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml
new file mode 100644
index 000000000000..aca42932b833
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+</pkgmetadata>