summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_Highlighter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Text_Highlighter
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Text_Highlighter')
-rw-r--r--dev-php/PEAR-Text_Highlighter/Manifest5
-rw-r--r--dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild33
-rw-r--r--dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.8.0.ebuild20
-rw-r--r--dev-php/PEAR-Text_Highlighter/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Highlighter/Manifest b/dev-php/PEAR-Text_Highlighter/Manifest
new file mode 100644
index 000000000000..46f20a90476a
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/Manifest
@@ -0,0 +1,5 @@
+DIST Text_Highlighter-0.7.3.tgz 138384 BLAKE2B 9cffd6dbe3eadf0a6e0465a6845bdc63f3b4b30af3bb09a7ac90cbb42575d0a98a3d8adf9e4f6e2f9e67d978a035a27e83bccd799f88513af72c492ad6241037 SHA512 59924cffbec8e4b652525f718012aa9a4f17d348401e191e292643df1e75a2a1b8687b7df701363816fcead1c55efe281a68b126f87df14806acd69ae6f44209
+DIST Text_Highlighter-0.8.0.tgz 138657 BLAKE2B d2d1c9374f5b2ac88c1bca7e91723e0a67ee8205f92b3d840669eda2f37cae9601f31eaf7373e4b32f5d4c36569115ed6777cfa562a1cd465a289f8f5f626a66 SHA512 9774fa613f95064629b749f2514e173275a4a15f46b649b208ca668ffc85118b5f26197ce3c9311fe8c1b200a76d30ed2e745929b0d4f1b54056732f4a5cfe05
+EBUILD PEAR-Text_Highlighter-0.7.3-r1.ebuild 864 BLAKE2B 3f7377c0d0a4f205b546d967e69fceb71fb202a3058ebc55b5a9ee166ca43c987236d0ec4f7ab3e7c5dc5167557024798b7e40f4bf4d4ee8a497f90a2f399c34 SHA512 44ae55d35ecd2563b236093a9bc1fdbeee0849f731e14c208e474f763f7d51be0c64c9f8ebc765baab575069b419612279a38defd4a1473aab2804cb8d27700c
+EBUILD PEAR-Text_Highlighter-0.8.0.ebuild 627 BLAKE2B 9ddf12412dc6d14d0b479d0042f043c3567876070f4e46148ca65a0da9d22488fcd646e2d2daff899ec8d01c4ffe736aadd6a16770dc1af38ea28f9329b4c531 SHA512 eca9ce847a3aa5ccd2d40d12886e7e0762b0e272a5c21dc3610b731fdf09bae9ef75e9570e83898a6c2933fee5cc91d8f0a8ac3bfe20a258eb96c9f8b2c8e393
+MISC metadata.xml 318 BLAKE2B 5253e98310510ca989d8e961869367b1dc99ab14c71fe435439377991dc9a9e774319ae082bbceea306b51ba822867c17fe4483ae37df94e0dbf37b7a87c001a SHA512 685d80a2af63fb76899a86132a149a086a3d38b14b4ee98b10d30b591492cf503fffe75e4065d99d81843579dc836cc4401f8cb461a2e4a85f658ec35cb657c9
diff --git a/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..4ddca264aecd
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for syntax highlighting"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# There is a documented dependency on XML_Parser, but that's only needed
+# for development -- if you want to *generate* the PHP class files. The
+# ones in the release are already pre-generated. The dependency on the
+# XML_Serializer, on the other hand, is not documented but is requird
+# by the XML output renderer.
+RDEPEND="dev-lang/php
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-XML_Serializer"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc README TODO
+
+ insinto /usr/share/php
+ doins -r Text
+}
diff --git a/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.8.0.ebuild b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.8.0.ebuild
new file mode 100644
index 000000000000..c3c25710ef34
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.8.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="A package for syntax highlighting"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# There is a documented dependency on XML_Parser, but that's only needed
+# for development -- if you want to *generate* the PHP class files. The
+# ones in the release are already pre-generated. The dependency on the
+# XML_Serializer, on the other hand, is not documented but is requird
+# by the XML output renderer.
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
+ dev-php/PEAR-XML_Serializer"
diff --git a/dev-php/PEAR-Text_Highlighter/metadata.xml b/dev-php/PEAR-Text_Highlighter/metadata.xml
new file mode 100644
index 000000000000..a9eda71d7435
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Text_Highlighter</remote-id>
+ </upstream>
+</pkgmetadata>