summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-System_Command
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-System_Command
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-System_Command')
-rw-r--r--dev-php/PEAR-System_Command/Manifest3
-rw-r--r--dev-php/PEAR-System_Command/PEAR-System_Command-1.0.8-r1.ebuild27
-rw-r--r--dev-php/PEAR-System_Command/metadata.xml12
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/PEAR-System_Command/Manifest b/dev-php/PEAR-System_Command/Manifest
new file mode 100644
index 000000000000..0ea726ec398d
--- /dev/null
+++ b/dev-php/PEAR-System_Command/Manifest
@@ -0,0 +1,3 @@
+DIST System_Command-1.0.8.tgz 6528 BLAKE2B b1aaf2a55f65cd020d7d619dae7c758480241f2be77eea0777cab12ad904522b8e4d8021168e1455fa8c89fabfc87c7e89a581af267dbfbab174898b0d6b8e97 SHA512 37aa9624fe566cdd8613ffd021ba32c2a3f0818b8881933dc1c2e12e2e03773b98b4295b46ef54baca26fb07015c0db2b87e44136f46c09f820994905241acee
+EBUILD PEAR-System_Command-1.0.8-r1.ebuild 585 BLAKE2B 32b45d4c4d426337c82b7b4549aaf5c593bec06a028ff03362d6a297719c5ea3958d2a72a4d4a2772a8ae74e3df23ac2357cfa2b1a98d121f9d736b581c1a796 SHA512 124908bdb8388bd2a0097c9b57bcb90bed78e3b2e49b36714c372da584a09b51ffbe523fca1320c01a6e038e31d8fcc57be547e70e995da2dc405ab298f59439
+MISC metadata.xml 387 BLAKE2B fde6b0c7f1677ebc0e0e40377031d806dae236925943478e278552d9b54c6db74dc9096f975731293f0edb2493faf453d3c830e29c2678257ffa08b72c02e9f6 SHA512 c0b80ef4a3417735c450179e72e2aa67528225c307d64b4ee214e6c1c765529fe0d031c378c4f7570681843a7c5fa6eec9b224d903befc55b2e362cb10128dd0
diff --git a/dev-php/PEAR-System_Command/PEAR-System_Command-1.0.8-r1.ebuild b/dev-php/PEAR-System_Command/PEAR-System_Command-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..a13d8e50ad5d
--- /dev/null
+++ b/dev-php/PEAR-System_Command/PEAR-System_Command-1.0.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PHP command-line execution interface"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ use examples && dodoc -r docs/test.php
+
+ insinto /usr/share/php
+ doins -r System
+}
diff --git a/dev-php/PEAR-System_Command/metadata.xml b/dev-php/PEAR-System_Command/metadata.xml
new file mode 100644
index 000000000000..4cf233814b10
--- /dev/null
+++ b/dev-php/PEAR-System_Command/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/System_Command</remote-id>
+ <remote-id type="pear">System_Command</remote-id>
+ </upstream>
+</pkgmetadata>