summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Services_JSON
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-php/PEAR-Services_JSON
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-php/PEAR-Services_JSON')
-rw-r--r--dev-php/PEAR-Services_JSON/Manifest4
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild19
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3.ebuild12
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch42
-rw-r--r--dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch20
5 files changed, 84 insertions, 13 deletions
diff --git a/dev-php/PEAR-Services_JSON/Manifest b/dev-php/PEAR-Services_JSON/Manifest
index ba88dd22f1d3..4a4443c817f3 100644
--- a/dev-php/PEAR-Services_JSON/Manifest
+++ b/dev-php/PEAR-Services_JSON/Manifest
@@ -1,3 +1,5 @@
+AUX JSON-1.0.3-constructor.patch 1705 BLAKE2B fe8af8e0f1b3ff1632dc55501484e803d612b4a4c7b8dc5ede6ad57af95286574f213f87901e9491515582eab4dc0b48de2dc43995eb7d27e9bb69630ce0d74a SHA512 e61b88d35cb9a58622e0e7c58767306712cd9a39c908e64f0c2e2e51f277a43b2d0af177c1050d0bfc8c7fa387d868949644c62554f9a8d3f83157b3ec8577e5
+AUX JSON-1.0.3-upstream-typo.patch 758 BLAKE2B 9a443f2a4f9a52df75b11c46522d6894872dbfe97db165ce595b4237f773a6bf8143b4a1d1335282baf32487cd22403f444175ea62b40aed87dfec083a16d6d5 SHA512 455b44ac00f6efb8eae96f2a2cc83aa2c3d36f318e587f0412e45338625dd2566facdf9ff042f97d98780a25bd9d5ddd8a81faa422ba9afd211e3df4e7b30976
DIST Services_JSON-1.0.3.tgz 9529 BLAKE2B 5a35899d53b66f3534afd64105c361e7aafa22641f540ef5ed38789ccc771f4e62577b1044af8d617579aed36e014e38e6bc30f39b476b09b47202d8822028d7 SHA512 2a94bebb662e250d56ae1f02f6debbff9e956820a603b8c4520f48ad0ed67a40c342d4eb000be9a9cf0e5b91c7bf9ebf98fae87f9ecca217b94b12441b746e5e
-EBUILD PEAR-Services_JSON-1.0.3.ebuild 283 BLAKE2B 18e1621f1b200f782fdf4e24048f76f58ac3091b8e3a7b3ea3c9ed5b585b2f6b33ab68e1c2b40429bf1158aa088a8609f420edd12ba571f36326fe5eb5508d9d SHA512 1e66e0af3fa5882a0a209bdbe7723cff27e180734d5f0445fea349c955a114ea19c19a5ff204f93392c8f174043dc2fd37073dc9e426911670d70a712dbb3a12
+EBUILD PEAR-Services_JSON-1.0.3-r1.ebuild 476 BLAKE2B ad30d170717d858beaf1b956759ea4374d0eb66f2b8ede32c929efe55c949cd199994053b412d8858e38db724b1ad81492b9ecf2c3e94d07a7a9491339d060ef SHA512 eb642f611fbdb5617d0cf19a6ac03d66f8514ff9f57bc567c07a3d2ae0070e744de8d0b84339f85e1edc53e6245e65a403551b02de70a7ed38b4d901ee3e7847
MISC metadata.xml 235 BLAKE2B 5b10304feea18aae1822be7d29bcce06c8715193b14a3dd2c4d79eb75e2767670352e2ca11e06b9a10ec04b63020a18254cd167e6d6be9072f4a200ca5d11ec4 SHA512 0b3e95bbf68eddf74289dad50f8828cffce2d904ff6f9bd5468177de979677cac11da84d1e0302c52b72085915b9d1b3496107172e5726520d51dad1981daf64
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..9e52d443b4b0
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+IUSE=""
+DESCRIPTION="PHP implementaion of json_encode/decode"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+PATCHES=( "${FILESDIR}/JSON-1.0.3-upstream-typo.patch" "${FILESDIR}/JSON-1.0.3-constructor.patch" )
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Services
+ doins JSON.php
+}
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3.ebuild
deleted file mode 100644
index a947e5e37ffb..000000000000
--- a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3.ebuild
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit php-pear-r1
-
-IUSE=""
-DESCRIPTION="PHP implementaion of json_encode/decode"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
new file mode 100644
index 000000000000..d7348f0f858e
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-constructor.patch
@@ -0,0 +1,42 @@
+diff -aurN a/JSON.php b/JSON.php
+--- a/JSON.php 2011-01-13 21:40:48.000000000 -0500
++++ b/JSON.php 2018-02-15 11:42:06.551287857 -0500
+@@ -139,6 +139,14 @@
+ * strings or numbers, if you return an object, make sure it does
+ * not have a toJSON method, otherwise an error will occur.
+ */
++ function __construct($use = 0)
++ {
++ $this->use = $use;
++ $this->_mb_strlen = function_exists('mb_strlen');
++ $this->_mb_convert_encoding = function_exists('mb_convert_encoding');
++ $this->_mb_substr = function_exists('mb_substr');
++ }
++
+ function Services_JSON($use = 0)
+ {
+ $this->use = $use;
+@@ -909,6 +917,11 @@
+
+ class Services_JSON_Error extends PEAR_Error
+ {
++ function __construct($message = 'unknown error', $code = null,
++ $mode = null, $options = null, $userinfo = null)
++ {
++ parent::__construct($message, $code, $mode, $options, $userinfo);
++ }
+ function Services_JSON_Error($message = 'unknown error', $code = null,
+ $mode = null, $options = null, $userinfo = null)
+ {
+@@ -923,6 +936,11 @@
+ */
+ class Services_JSON_Error
+ {
++ function __construct($message = 'unknown error', $code = null,
++ $mode = null, $options = null, $userinfo = null)
++ {
++ return;
++ }
+ function Services_JSON_Error($message = 'unknown error', $code = null,
+ $mode = null, $options = null, $userinfo = null)
+ {
diff --git a/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
new file mode 100644
index 000000000000..c7d8be3aa910
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/files/JSON-1.0.3-upstream-typo.patch
@@ -0,0 +1,20 @@
+--- a/JSON.php 2011/01/28 00:16:42 307804
++++ b/JSON.php 2013/04/30 02:37:26 330165
+@@ -554,7 +544,7 @@
+
+ return ($this->use & SERVICES_JSON_SUPPRESS_ERRORS)
+ ? 'null'
+- : new Services_JSON_Error(class_name($var).
++ : new Services_JSON_Error(get_class($var).
+ " toJSON returned an object with a toJSON method.");
+
+ }
+@@ -995,7 +985,7 @@
+ function Services_JSON_Error($message = 'unknown error', $code = null,
+ $mode = null, $options = null, $userinfo = null)
+ {
+-
++ return;
+ }
+ }
+