summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild')
-rw-r--r--dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..129b730b505e
--- /dev/null
+++ b/dev-php/PEAR-Net_LDAP2/PEAR-Net_LDAP2-2.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+DESCRIPTION="OO interface for searching and manipulating LDAP-entries"
+HOMEPAGE="https://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_PN}-${PV}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="examples test"
+
+RDEPEND="dev-lang/php:*[ldap]
+ dev-php/PEAR-PEAR"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ use examples && dodoc -r doc/examples
+ dodoc doc/*.*
+ insinto /usr/share/php
+ doins -r Net
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}